Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Memory Efficient Serialization Library" |
| 2 | HOMEPAGE = "https://github.com/google/flatbuffers" |
| 3 | SECTION = "console/tools" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | |
| 6 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 7 | |
| 8 | RDEPENDS_${PN}-compiler = "${PN}" |
| 9 | RDEPENDS_${PN}-dev += "${PN}-compiler" |
| 10 | |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a873c5645c184d51e0f9b34e1d7cf559" |
| 12 | |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 13 | SRCREV = "9e7e8cbe9f675123dd41b7c62868acad39188cae" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 15 | SRC_URI = "git://github.com/google/flatbuffers.git \ |
| 16 | file://0001-Add-detection-of-strtoull_l-function.patch \ |
| 17 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | |
| 19 | # Make sure C++11 is used, required for example for GCC 4.9 |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 20 | CXXFLAGS += "-std=c++11 -fPIC" |
| 21 | BUILD_CXXFLAGS += "-std=c++11 -fPIC" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | |
| 23 | # BUILD_TYPE=Release is required, otherwise flatc is not installed |
| 24 | EXTRA_OECMAKE += "\ |
| 25 | -DCMAKE_BUILD_TYPE=Release \ |
| 26 | -DFLATBUFFERS_BUILD_TESTS=OFF \ |
| 27 | -DFLATBUFFERS_BUILD_SHAREDLIB=ON \ |
| 28 | " |
| 29 | |
| 30 | inherit cmake |
| 31 | |
| 32 | S = "${WORKDIR}/git" |
| 33 | |
| 34 | FILES_${PN}-compiler = "${bindir}" |
| 35 | |
| 36 | BBCLASSEXTEND = "native nativesdk" |