James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 1 | SUMMARY = "JSON for modern C++" |
| 2 | HOMEPAGE = "https://nlohmann.github.io/json/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=f5f7c71504da070bcf4f090205ce1080" |
James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 6 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 7 | SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1" |
James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 8 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 9 | SRCREV = "e7b3b40b5a95bc74b9a7f662830a27c49ffc01b4" |
James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit cmake |
| 14 | |
| 15 | EXTRA_OECMAKE += "-DJSON_BuildTests=OFF" |
| 16 | |
| 17 | # nlohmann-json is a header only C++ library, so the main package will be empty. |
| 18 | |
| 19 | RDEPENDS_${PN}-dev = "" |
| 20 | |
| 21 | BBCLASSEXTEND = "native nativesdk" |
James Feist | cb07cdf | 2018-10-11 13:47:04 -0700 | [diff] [blame] | 22 | |
| 23 | # other packages commonly reference the file directly as "json.hpp" |
| 24 | # create symlink to allow this usage |
| 25 | do_install_append() { |
| 26 | ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp |
| 27 | } |