Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Very fast, header only, C++ logging library." |
| 2 | HOMEPAGE = "https://github.com/gabime/spdlog/wiki" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
| 5 | |
| 6 | SRCREV = "a7148b718ea2fabb8387cb90aee9bf448da63e65" |
| 7 | SRC_URI = "git://github.com/gabime/spdlog.git;protocol=git;branch=v1.x;" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | BBCLASSEXTEND = "native" |
| 12 | # no need to build example&text&benchmarks on pure yocto |
| 13 | EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_EXAMPLES=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off" |
| 14 | |
| 15 | inherit cmake |
| 16 | |
| 17 | # Header-only library |
| 18 | RDEPENDS_${PN}-dev = "" |
| 19 | RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})" |