Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 1 | DESCRIPTION = "CGI.pm is a stable, complete and mature solution for processing and preparing \ |
| 2 | HTTP requests and responses. Major features including processing form \ |
| 3 | submissions, file uploads, reading and writing cookies, query string generation \ |
| 4 | and manipulation, and processing and preparing HTTP headers." |
| 5 | HOMEPAGE = "http://search.cpan.org/~leejo/CGI-4.28/lib/CGI.pod" |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "Artistic-2.0 | GPL-2.0" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=415fc49abed2728f9480cd32c8d67beb" |
| 10 | |
| 11 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/L/LE/LEEJO/CGI-${PV}.tar.gz" |
| 12 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 13 | SRC_URI[md5sum] = "2cbe560fdadbb8b9237744e39bbfc3eb" |
| 14 | SRC_URI[sha256sum] = "12435fb7ebd3585c47b6d60ee4f5c7d6a7c114a2827d2b5acf3d62aa9fcf1208" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/CGI-${PV}" |
| 17 | |
| 18 | inherit cpan ptest-perl |
| 19 | |
| 20 | RDEPENDS_${PN} += "\ |
| 21 | libhtml-parser-perl \ |
| 22 | perl-module-base \ |
| 23 | perl-module-deprecate \ |
| 24 | perl-module-if \ |
| 25 | " |
| 26 | |
| 27 | do_install_prepend() { |
| 28 | # requires "-T" (taint) command line option |
| 29 | rm -rf ${B}/t/push.t |
| 30 | rm -rf ${B}/t/utf8.t |
| 31 | # tests building of docs |
| 32 | rm -rf ${B}/t/compiles_pod.t |
| 33 | } |
| 34 | |
| 35 | RDEPENDS_${PN}-ptest += " \ |
| 36 | libtest-deep-perl \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 37 | libtest-warn-perl \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 38 | perl-module-bytes \ |
| 39 | perl-module-file-find \ |
| 40 | perl-module-filehandle \ |
| 41 | perl-module-findbin \ |
| 42 | perl-module-lib \ |
| 43 | perl-module-perlio \ |
| 44 | perl-module-perlio-scalar \ |
| 45 | perl-module-test-more \ |
| 46 | perl-module-utf8 \ |
| 47 | " |
| 48 | |
| 49 | RPROVIDES_${PN} += "perl-module-cgi" |
| 50 | |
| 51 | BBCLASSEXTEND = "native" |