Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Xfce4 Window Manager" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 2 | SECTION = "x11/wm" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d791728a073bc009b4ffaf00b7599855" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 5 | DEPENDS = "virtual/libx11 libxfce4ui libwnck3 libxinerama exo-native" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 6 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 7 | inherit xfce update-alternatives features_check |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | |
| 9 | REQUIRED_DISTRO_FEATURES = "x11" |
| 10 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 11 | SRC_URI += "file://0001-Revert-compositor-Revert-to-GLX-as-default-vblank-me.patch" |
| 12 | SRC_URI[md5sum] = "c33847836958d540e3ecd0a27f131c0f" |
| 13 | SRC_URI[sha256sum] = "b4182bf8dc63d092f120a51fcae0eb54b9bd4aa4f8486f47e5a65a108322b615" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | |
| 15 | PACKAGECONFIG ?= " \ |
| 16 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'epoxy', '', d)} \ |
| 17 | xpresent \ |
| 18 | startup-notification \ |
| 19 | " |
| 20 | |
| 21 | PACKAGECONFIG[epoxy] = "--enable-epoxy,--disable-epoxy,libepoxy" |
| 22 | PACKAGECONFIG[xpresent] = "--enable-xpresent,--disable-xpresent,libxpresent" |
| 23 | PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification" |
| 24 | |
| 25 | python populate_packages_prepend () { |
| 26 | themedir = d.expand('${datadir}/themes') |
| 27 | do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True) |
| 28 | } |
| 29 | |
| 30 | PACKAGES_DYNAMIC += "^xfwm4-theme-.*" |
| 31 | |
| 32 | ALTERNATIVE_${PN} = "x-window-manager" |
| 33 | ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/xfwm4" |
| 34 | ALTERNATIVE_PRIORITY[x-window-manager] = "30" |
| 35 | |
| 36 | RDEPENDS_${PN} = "xfwm4-theme-default" |
| 37 | FILES_${PN} += "${libdir}/xfce4/xfwm4/helper-dialog \ |
| 38 | ${datadir}/xfwm4/defaults \ |
| 39 | " |