Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "System call tracing tool" |
| 2 | HOMEPAGE = "http://strace.io" |
| 3 | SECTION = "console/utils" |
| 4 | LICENSE = "LGPL-2.1+ & GPL-2+" |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=0169a04810830e94f4b1cfb823c9f592" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | |
| 7 | SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \ |
| 8 | file://disable-git-version-gen.patch \ |
| 9 | file://more-robust-test-for-m32-mx32-compile-support.patch \ |
| 10 | file://update-gawk-paths.patch \ |
| 11 | file://Makefile-ptest.patch \ |
| 12 | file://run-ptest \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | file://mips-SIGEMT.patch \ |
| 14 | file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \ |
| 15 | file://0001-tests-sigaction-Check-for-mips-and-alpha-before-usin.patch \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 16 | file://ptest-spacesave.patch \ |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 17 | file://uintptr_t.patch \ |
| 18 | file://sys_headers.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 19 | " |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 20 | SRC_URI[md5sum] = "84f5e72de813c9b1bb6057ee8ab428d8" |
| 21 | SRC_URI[sha256sum] = "6c131198749656401fe3efd6b4b16a07ea867e8f530867ceae8930bbc937a047" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 23 | inherit autotools ptest |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | |
| 25 | PACKAGECONFIG_class-target ??= "\ |
| 26 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ |
| 27 | " |
| 28 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 29 | PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 30 | PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind" |
| 31 | |
| 32 | EXTRA_OECONF += "--enable-mpers=no" |
| 33 | |
| 34 | CFLAGS_append_libc-musl = " -Dsigcontext_struct=sigcontext" |
| 35 | |
| 36 | TESTDIR = "tests" |
| 37 | PTEST_BUILD_HOST_PATTERN = "^(DEB_CHANGELOGTIME|RPM_CHANGELOGTIME|WARN_CFLAGS_FOR_BUILD|LDFLAGS_FOR_BUILD)" |
| 38 | |
| 39 | do_install_append() { |
| 40 | # We don't ship strace-graph here because it needs perl |
| 41 | rm ${D}${bindir}/strace-graph |
| 42 | } |
| 43 | |
| 44 | do_compile_ptest() { |
| 45 | oe_runmake -C ${TESTDIR} buildtest-TESTS |
| 46 | } |
| 47 | |
| 48 | do_install_ptest() { |
| 49 | oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR} |
| 50 | install -m 755 ${S}/test-driver ${D}${PTEST_PATH} |
| 51 | install -m 644 ${B}/config.h ${D}${PTEST_PATH} |
| 52 | sed -i -e '/^src/s/strace.*[1-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile |
| 53 | } |
| 54 | |
| 55 | RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed" |
| 56 | |
| 57 | BBCLASSEXTEND = "native" |
| 58 | TOOLCHAIN = "gcc" |