Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Ice Window Manager (IceWM)" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=4a26952467ef79a7efca4a9cf52d417b" |
| 4 | |
| 5 | SRC_URI = "https://github.com/ice-wm/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz \ |
| 6 | file://0001-configure.ac-skip-running-test-program-when-cross-co.patch \ |
| 7 | " |
| 8 | SRC_URI[md5sum] = "6eba94a7935a0531d2c14eeb1426aeef" |
| 9 | SRC_URI[sha256sum] = "f1c1344b20a9e8635143f70ee27930b55f813c15ca61f84d77584d311b6ac027" |
| 10 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame^] | 11 | inherit autotools pkgconfig gettext perlnative features_check qemu |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 12 | REQUIRED_DISTRO_FEATURES = "x11" |
| 13 | |
| 14 | EXTRA_OECONF += "--with-libdir=${datadir}/icewm \ |
| 15 | --with-cfgdir=${sysconfdir}/icewm \ |
| 16 | --with-docdir=${docdir}/icewm \ |
| 17 | --enable-fribidi \ |
| 18 | --enable-xinerama \ |
| 19 | --enable-shape" |
| 20 | |
| 21 | DEPENDS = "asciidoc-native fontconfig gdk-pixbuf libxft libxpm libxrandr libxinerama libice libsm libx11 libxext libxrender" |
| 22 | DEPENDS_append = " qemu-native" |
| 23 | RDEPENDS_${PN} = "perl fribidi" |
| 24 | |
| 25 | do_compile_prepend_class-target() { |
| 26 | |
| 27 | cd ${B} |
| 28 | oe_runmake -C src genpref |
| 29 | |
| 30 | qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}',['${B}/src/.libs','${STAGING_DIR_TARGET}/${libdir}','${STAGING_DIR_TARGET}/${base_libdir}'])}" |
| 31 | cat >qemuwrapper <<EOF |
| 32 | #!/bin/sh |
| 33 | ${qemu_binary} src/genpref "\$@" |
| 34 | EOF |
| 35 | chmod +x qemuwrapper |
| 36 | ./qemuwrapper > src/preferences |
| 37 | } |
| 38 | |
| 39 | FILES_${PN} += "${datadir}/xsessions" |