Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Set of CLI tools for Openlmi providers" |
| 2 | DESCRIPTION = "openlmi-tools is a set of command line tools for Openlmi providers." |
| 3 | HOMEPAGE = "http://www.openlmi.org/" |
| 4 | LICENSE = "GPLv2+" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://../COPYING;md5=75859989545e37968a99b631ef42722e" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | SECTION = "System/Management" |
| 7 | |
| 8 | inherit setuptools |
| 9 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 10 | DEPENDS = "python-native python-pywbem-native python-m2crypto python-pywbem" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
| 12 | SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \ |
| 13 | " |
| 14 | SRC_URI[md5sum] = "e156246cb7b49753db82f4ddf7f03e50" |
| 15 | SRC_URI[sha256sum] = "292b8f5f2250655a4add8183c529b73358bc980bd4f23cfa484a940953fce9e4" |
| 16 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | S = "${WORKDIR}/${BP}/cli" |
| 18 | |
| 19 | do_configure_prepend() { |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 20 | sed 's/@@VERSION@@/$(VERSION)/g' setup.py.skel >setup.py |
| 21 | } |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 22 | |
| 23 | python() { |
| 24 | if 'meta-python' not in d.getVar('BBFILE_COLLECTIONS').split(): |
| 25 | raise bb.parse.SkipRecipe('Requires meta-python to be present.') |
| 26 | } |