Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 1 | SUMMARY = "copy-paste for the Linux console" |
| 2 | DESCRIPTION = "Consolation is a daemon that provides copy-paste and scrolling \ |
| 3 | support to the Linux console. It is based on the libinput library and \ |
| 4 | supports all pointer devices and settings provided by this library. Similar \ |
| 5 | software include gpm and jamd." |
| 6 | HOMEPAGE = "https://salsa.debian.org/consolation-team/consolation" |
| 7 | SECTION = "console/utils" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 8 | LICENSE = "GPL-2.0-or-later" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7df9eea2f4dfdda489c116099e6fc062" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 10 | |
| 11 | DEPENDS = " \ |
| 12 | libevdev \ |
| 13 | libinput \ |
| 14 | udev \ |
| 15 | " |
| 16 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 17 | SRC_URI = "git://salsa.debian.org/consolation-team/consolation.git;branch=master" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 18 | SRCREV = "5ef08f0cd6ede62de14de477b74fc3611108c676" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit autotools pkgconfig systemd |
| 23 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 24 | do_install:append() { |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 25 | install -d ${D}${systemd_system_unitdir} |
| 26 | install -m 644 ${B}/consolation.service ${D}${systemd_system_unitdir} |
| 27 | } |
| 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | SYSTEMD_SERVICE:${PN} = "consolation.service" |