Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 1 | SUMMARY = "Get SD card health data" |
| 2 | HOMEPAGE = "https://github.com/Ognian/sdmon" |
| 3 | |
| 4 | LICENSE = "GPL-2.0-only" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | SRC_URI = "git://github.com/Ognian/sdmon;protocol=https;branch=master" |
| 8 | |
| 9 | PV = "0.8.1+git" |
| 10 | SRCREV = "ef1aec457f04a50721f0259651cca9c946f11390" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | do_compile() { |
| 15 | oe_runmake -C ${S}/src CC="${CC}" CFLAGS="${CFLAGS} -D_REENTRANT -DVERSION=\"\\\"${PV}\\\"\"" LDFLAGS="${LDFLAGS}" |
| 16 | } |
| 17 | |
| 18 | do_install() { |
| 19 | install -Dm 0755 ${S}/src/sdmon ${D}${bindir}/sdmon |
| 20 | } |