Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | require mariadb.inc |
| 2 | inherit native |
| 3 | |
| 4 | PROVIDES += "mysql5-native" |
| 5 | DEPENDS = "ncurses-native zlib-native bison-native libpcre2-native \ |
| 6 | gnutls-native fmt-native \ |
| 7 | " |
| 8 | |
| 9 | RDEPENDS:${PN} = "" |
| 10 | PACKAGES = "" |
| 11 | EXTRA_OEMAKE = "" |
| 12 | |
| 13 | do_install() { |
| 14 | oe_runmake 'DESTDIR=${D}' install |
| 15 | |
| 16 | install -d ${D}${bindir} |
| 17 | install -m 0755 sql/gen_lex_hash ${D}${bindir}/ |
| 18 | install -m 0755 sql/gen_lex_token ${D}${bindir}/ |
| 19 | install -m 0755 extra/comp_err ${D}${bindir}/ |
| 20 | install -m 0755 scripts/comp_sql ${D}${bindir}/ |
| 21 | install -m 0755 strings/uca-dump ${D}${bindir}/ |
| 22 | } |
| 23 | |