Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Header-only C++ library for JSON Schema validation" |
| 2 | HOMEPAGE = "https://github.com/tristanpenman/valijson" |
| 3 | LICENSE = "BSD-2-Clause" |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5c4583a434195e4f3b418e17c8ca2daf" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 5 | |
| 6 | SRC_URI = "git://github.com/tristanpenman/valijson.git;branch=master;protocol=https" |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 7 | SRCREV = "78ac8a737df56b5334354efe104ea8f99e2a2f00" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | inherit cmake |
| 12 | |
| 13 | PACKAGECONFIG ?= "boost" |
| 14 | |
| 15 | PACKAGECONFIG[boost] = "-Dvalijson_EXCLUDE_BOOST=FALSE,-Dvalijson_EXCLUDE_BOOST=TRUE,boost" |
| 16 | PACKAGECONFIG[examples] = "-Dvalijson_BUILD_EXAMPLES=TRUE,-Dvalijson_BUILD_EXAMPLES=FALSE,curlpp" |
| 17 | PACKAGECONFIG[tests] = "-Dvalijson_BUILD_TESTS=TRUE,-Dvalijson_BUILD_TESTS=FALSE,curlpp" |
| 18 | |
| 19 | # valijson is a header only C++ library, so the main package will be empty. |
| 20 | RDEPENDS:${PN}-dev = "" |
| 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |