Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "HTTP/2 C Library and tools" |
| 2 | HOMEPAGE = "https://nghttp2.org/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec" |
| 6 | |
| 7 | SRC_URI = "\ |
| 8 | ${GITHUB_BASE_URI}/download/v${PV}/nghttp2-${PV}.tar.xz \ |
| 9 | file://0001-fetch-ocsp-response-use-python3.patch \ |
| 10 | " |
| 11 | SRC_URI[sha256sum] = "66aa76d97c143f42295405a31413e5e7d157968dad9f957bb4b015b598882e6b" |
| 12 | |
| 13 | inherit cmake manpages python3native github-releases |
| 14 | PACKAGECONFIG[manpages] = "" |
| 15 | |
| 16 | # examples are never installed, and don't need to be built in the |
| 17 | # first place |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame^] | 18 | EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF -DENABLE_PYTHON_BINDINGS=OFF" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 19 | |
| 20 | PACKAGES =+ "lib${BPN} ${PN}-client ${PN}-proxy ${PN}-server" |
| 21 | |
| 22 | RDEPENDS:${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})" |
| 23 | RDEPENDS:${PN}:class-native = "" |
| 24 | RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell" |
| 25 | |
| 26 | ALLOW_EMPTY:${PN} = "1" |
| 27 | FILES:${PN} = "" |
| 28 | FILES:lib${BPN} = "${libdir}/*${SOLIBS}" |
| 29 | FILES:${PN}-client = "${bindir}/h2load ${bindir}/nghttp" |
| 30 | FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response" |
| 31 | FILES:${PN}-server = "${bindir}/nghttpd" |
| 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |