blob: a5a5605dae2bf7fd81aecd9b7ab1fd3b3ea2cfac [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "This is a userland SCTP stack supporting FreeBSD, Linux, Mac OS X and Windows."
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE.md;md5=ffcf846341f3856d79a483eafa18e2a5"
4
Brad Bishop868407c2019-11-04 13:24:47 -05005SRCREV = "a10cd498d964508c0e6ec6bd2be9dd4afcbb4d86"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006SRC_URI = "git://github.com/sctplab/usrsctp;protocol=https;branch=master \
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007 "
8
9S = "${WORKDIR}/git"
10
11inherit autotools pkgconfig
12
13DEPENDS += "openssl"
14
15CFLAGS += "-DSCTP_USE_OPENSSL_SHA1 -fPIC"
16LDFLAGS += "-lssl -lcrypto"
17
18PACKAGECONFIG ?= "disablewarnings inet inet6"
19PACKAGECONFIG[disablewarnings] = "--disable-warnings-as-errors,,"
20PACKAGECONFIG[inet] = "--enable-inet,--disable-inet,"
21PACKAGECONFIG[inet6] = "--enable-inet6,--disable-inet6,"
22
23EXTRA_OECONF += "--disable-debug"