Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "A GObject-based Exiv2 wrapper" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 2 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=625f055f41728f84a8d7938acc35bdc2" |
| 4 | |
| 5 | DEPENDS = "exiv2 python3-pygobject-native" |
| 6 | |
| 7 | GNOMEBASEBUILDCLASS = "meson" |
| 8 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 9 | |
| 10 | inherit gnomebase gobject-introspection gtk-doc python3native |
| 11 | |
| 12 | SRC_URI[archive.sha256sum] = "e58279a6ff20b6f64fa499615da5e9b57cf65ba7850b72fafdf17221a9d6d69e" |
| 13 | |
| 14 | EXTRA_OEMESON = " \ |
| 15 | -Dvapi=false \ |
| 16 | -Dpython3_girdir=${PYTHON_SITEPACKAGES_DIR}/gi/overrides \ |
| 17 | " |
| 18 | |
| 19 | PACKAGES =+ "${PN}-python3" |
| 20 | FILES:${PN}-python3 = "${PYTHON_SITEPACKAGES_DIR}" |
| 21 | RDEPENDS:${PN}-python3 = "${PN}" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame^] | 22 | |
| 23 | PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess" |
| 24 | src_package_preprocess () { |
| 25 | # Trim build paths from comments in generated sources to ensure reproducibility |
| 26 | sed -i -e "s,${B}/../${BPN}-${PV}/${BPN}/,,g" \ |
| 27 | ${B}/gexiv2/gexiv2-enums.cpp |
| 28 | } |