Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 1 | SUMMARY = "A GNU tool that produce shell scripts to automatically configure software" |
| 2 | DESCRIPTION = "Autoconf is an extensible package of M4 macros that produce shell scripts to automatically \ |
| 3 | configure software source code packages. Autoconf creates a configuration script for a package from a template \ |
| 4 | file that lists the operating system features that the package can use, in the form of M4 macro calls." |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-3.0-or-later" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 6 | HOMEPAGE = "http://www.gnu.org/software/autoconf/" |
| 7 | SECTION = "devel" |
| 8 | DEPENDS = "m4-native autoconf-native automake-native gnu-config-native help2man-native" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 9 | DEPENDS:remove:class-native = "autoconf-native automake-native help2man-native" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 10 | |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=cc3f3a7596cb558bbd9eb7fbaa3ef16c \ |
| 12 | file://COPYINGv3;md5=1ebbd3e34237af26da5dc08a4e440464" |
| 13 | |
| 14 | SRC_URI = "${GNU_MIRROR}/autoconf/${BP}.tar.gz \ |
| 15 | file://program_prefix.patch \ |
| 16 | file://autoreconf-exclude.patch \ |
| 17 | file://remove-usr-local-lib-from-m4.patch \ |
| 18 | file://preferbash.patch \ |
| 19 | file://autotest-automake-result-format.patch \ |
| 20 | file://man-host-perl.patch \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame^] | 21 | file://0001-Port-to-compilers-that-moan-about-K-R-func-decls.patch \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 22 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | SRC_URI:append:class-native = " file://no-man.patch" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 24 | |
| 25 | SRC_URI[sha256sum] = "431075ad0bf529ef13cb41e9042c542381103e80015686222b8a9d4abef42a1c" |
| 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | RDEPENDS:${PN} = "m4 gnu-config \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 28 | perl \ |
| 29 | perl-module-bytes \ |
| 30 | perl-module-carp \ |
| 31 | perl-module-constant \ |
| 32 | perl-module-data-dumper \ |
| 33 | perl-module-errno \ |
| 34 | perl-module-exporter \ |
| 35 | perl-module-file-basename \ |
| 36 | perl-module-file-compare \ |
| 37 | perl-module-file-copy \ |
| 38 | perl-module-file-find \ |
| 39 | perl-module-file-glob \ |
| 40 | perl-module-file-path \ |
| 41 | perl-module-file-spec \ |
| 42 | perl-module-file-spec-unix \ |
| 43 | perl-module-file-stat \ |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 44 | perl-module-file-temp \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 45 | perl-module-getopt-long \ |
| 46 | perl-module-io-file \ |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 47 | perl-module-list-util \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 48 | perl-module-overloading \ |
| 49 | perl-module-posix \ |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 50 | perl-module-scalar-util \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 51 | perl-module-symbol \ |
| 52 | perl-module-thread-queue \ |
| 53 | perl-module-threads \ |
| 54 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 55 | RDEPENDS:${PN}:class-native = "m4-native gnu-config-native hostperl-runtime-native" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 56 | |
| 57 | inherit autotools texinfo |
| 58 | |
| 59 | PERL = "${USRBINPATH}/perl" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 60 | PERL:class-native = "/usr/bin/env perl" |
| 61 | PERL:class-nativesdk = "/usr/bin/env perl" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 62 | |
| 63 | CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'" |
| 64 | |
| 65 | EXTRA_OECONF += "ac_cv_path_M4=m4 ac_cv_prog_TEST_EMACS=no" |
| 66 | |
| 67 | # As autoconf installs its own config.* files, ensure that they're always up to date. |
| 68 | update_gnu_config() { |
| 69 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/build-aux |
| 70 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/build-aux |
| 71 | } |
| 72 | do_configure[prefuncs] += "update_gnu_config" |
| 73 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 74 | do_configure:class-native() { |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 75 | oe_runconf |
| 76 | } |
| 77 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 78 | do_install:append() { |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 79 | rm -rf ${D}${datadir}/emacs |
| 80 | } |
| 81 | |
| 82 | BBCLASSEXTEND = "native nativesdk" |