Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "The RPM package management system" |
| 2 | DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \ |
| 3 | package management system capable of installing, uninstalling, \ |
| 4 | verifying, querying, and updating software packages. Each software \ |
| 5 | package consists of an archive of files along with information about \ |
| 6 | the package like its version, a description, etc." |
| 7 | |
| 8 | SUMMARY_${PN}-dev = "Development files for manipulating RPM packages" |
| 9 | DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \ |
| 10 | development files will simplify the process of writing programs that \ |
| 11 | manipulate RPM packages and databases. These files are intended to \ |
| 12 | simplify the process of creating graphical package managers or any \ |
| 13 | other tools that need an intimate knowledge of RPM packages in order \ |
| 14 | to function." |
| 15 | |
| 16 | SUMMARY_python3-rpm = "Python bindings for apps which will manupulate RPM packages" |
| 17 | DESCRIPTION_python3-rpm = "The python3-rpm package contains a module that permits applications \ |
| 18 | written in the Python programming language to use the interface \ |
| 19 | supplied by the RPM Package Manager libraries." |
| 20 | |
| 21 | HOMEPAGE = "http://www.rpm.org" |
| 22 | |
| 23 | # libraries are also LGPL - how to express this? |
| 24 | LICENSE = "GPL-2.0" |
| 25 | LIC_FILES_CHKSUM = "file://COPYING;md5=c0bf017c0fd1920e6158a333acabfd4a" |
| 26 | |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 27 | SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.15.x \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | file://0001-Do-not-add-an-unsatisfiable-dependency-when-building.patch \ |
| 29 | file://0001-Do-not-read-config-files-from-HOME.patch \ |
| 30 | file://0001-When-cross-installing-execute-package-scriptlets-wit.patch \ |
| 31 | file://0001-Do-not-reset-the-PATH-environment-variable-before-ru.patch \ |
| 32 | file://0002-Add-support-for-prefixing-etc-from-RPM_ETCCONFIGDIR-.patch \ |
| 33 | file://0001-Do-not-hardcode-lib-rpm-as-the-installation-path-for.patch \ |
| 34 | file://0001-Fix-build-with-musl-C-library.patch \ |
| 35 | file://0001-Add-a-color-setting-for-mips64_n32-binaries.patch \ |
| 36 | file://0011-Do-not-require-that-ELF-binaries-are-executable-to-b.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 37 | file://0001-perl-disable-auto-reqs.patch \ |
| 38 | file://0001-rpm-rpmio.c-restrict-virtual-memory-usage-if-limit-s.patch \ |
| 39 | file://0016-rpmscript.c-change-logging-level-around-scriptlets-t.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 40 | file://0001-rpmplugins.c-call-dlerror-prior-to-dlsym.patch \ |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 41 | file://0001-rpmfc.c-do-not-run-file-classification-in-parallel.patch \ |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 42 | file://0001-lib-transaction.c-fix-file-conflicts-for-MIPS64-N32.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 43 | " |
| 44 | |
| 45 | PE = "1" |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 46 | SRCREV = "ab2179452c5be276a6b96c591afded485c7e58c3" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 47 | |
| 48 | S = "${WORKDIR}/git" |
| 49 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 50 | DEPENDS = "openssl libarchive db file popt xz bzip2 dbus elfutils python3" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 51 | DEPENDS_append_class-native = " file-replacement-native bzip2-replacement-native" |
| 52 | |
| 53 | inherit autotools gettext pkgconfig python3native |
| 54 | export PYTHON_ABI |
| 55 | |
| 56 | # OE-core patches autoreconf to additionally run gnu-configize, which fails with this recipe |
| 57 | EXTRA_AUTORECONF_append = " --exclude=gnu-configize" |
| 58 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 59 | EXTRA_OECONF_append = " --without-lua --enable-python --with-crypto=openssl" |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 60 | EXTRA_OECONF_append_libc-musl = " --disable-nls --disable-openmp" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 61 | |
| 62 | # --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs |
| 63 | # |
| 64 | # --localstatedir prevents rpm from writing its database to native sysroot when building images |
| 65 | # |
| 66 | # Disable dbus for native, so that rpm doesn't attempt to inhibit shutdown via session dbus even when plugins support is enabled. |
| 67 | # Also disable plugins by default for native. |
| 68 | EXTRA_OECONF_append_class-native = " --sysconfdir=/etc --localstatedir=/var --disable-plugins" |
| 69 | EXTRA_OECONF_append_class-nativesdk = " --sysconfdir=/etc --localstatedir=/var --disable-plugins" |
| 70 | |
| 71 | BBCLASSEXTEND = "native nativesdk" |
| 72 | |
| 73 | PACKAGECONFIG ??= "" |
| 74 | PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils" |
| 75 | |
| 76 | ASNEEDED = "" |
| 77 | |
| 78 | # Direct rpm-native to read configuration from our sysroot, not the one it was compiled in |
| 79 | # libmagic also has sysroot path contamination, so override it |
| 80 | |
| 81 | WRAPPER_TOOLS = " \ |
| 82 | ${bindir}/rpm \ |
| 83 | ${bindir}/rpm2archive \ |
| 84 | ${bindir}/rpm2cpio \ |
| 85 | ${bindir}/rpmbuild \ |
| 86 | ${bindir}/rpmdb \ |
| 87 | ${bindir}/rpmgraph \ |
| 88 | ${bindir}/rpmkeys \ |
| 89 | ${bindir}/rpmsign \ |
| 90 | ${bindir}/rpmspec \ |
| 91 | ${libdir}/rpm/rpmdeps \ |
| 92 | " |
| 93 | |
| 94 | do_install_append_class-native() { |
| 95 | for tool in ${WRAPPER_TOOLS}; do |
| 96 | create_wrapper ${D}$tool \ |
| 97 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \ |
| 98 | RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE} \ |
| 99 | MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \ |
| 100 | RPM_NO_CHROOT_FOR_SCRIPTS=1 |
| 101 | done |
| 102 | } |
| 103 | |
| 104 | do_install_append_class-nativesdk() { |
| 105 | for tool in ${WRAPPER_TOOLS}; do |
| 106 | create_wrapper ${D}$tool \ |
| 107 | RPM_CONFIGDIR='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir'), d.getVar('bindir'))}/rpm \ |
| 108 | RPM_ETCCONFIGDIR='$'{RPM_ETCCONFIGDIR-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir'), d.getVar('bindir'))}/..} \ |
| 109 | MAGIC='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir'), d.getVar('bindir'))}/misc/magic.mgc \ |
| 110 | RPM_NO_CHROOT_FOR_SCRIPTS=1 |
| 111 | done |
| 112 | |
| 113 | rm -rf ${D}/var |
| 114 | } |
| 115 | |
| 116 | # Rpm's make install creates var/tmp which clashes with base-files packaging |
| 117 | do_install_append_class-target() { |
| 118 | rm -rf ${D}/var |
| 119 | } |
| 120 | |
| 121 | do_install_append () { |
| 122 | sed -i -e 's:${HOSTTOOLS_DIR}/::g' \ |
| 123 | ${D}/${libdir}/rpm/macros |
| 124 | |
| 125 | sed -i -e 's|/usr/bin/python|${USRBINPATH}/env ${PYTHON_PN}|' \ |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 126 | ${D}${libdir}/rpm/pythondistdeps.py |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 127 | } |
| 128 | |
| 129 | FILES_${PN} += "${libdir}/rpm-plugins/*.so \ |
| 130 | " |
| 131 | |
| 132 | FILES_${PN}-dev += "${libdir}/rpm-plugins/*.la \ |
| 133 | " |
| 134 | |
| 135 | PACKAGES += "python3-rpm" |
| 136 | PROVIDES += "python3-rpm" |
| 137 | FILES_python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*" |
| 138 | |
| 139 | # rpm 5.x was packaging the rpm build tools separately |
| 140 | RPROVIDES_${PN} += "rpm-build" |
| 141 | |
| 142 | RDEPENDS_${PN} = "bash perl python3-core" |
| 143 | |
| 144 | PACKAGE_PREPROCESS_FUNCS += "rpm_package_preprocess" |
| 145 | |
| 146 | # Do not specify a sysroot when compiling on a target. |
| 147 | rpm_package_preprocess () { |
| 148 | sed -i -e 's:--sysroot[^ ]*::g' \ |
| 149 | ${PKGD}/${libdir}/rpm/macros |
| 150 | } |