blob: 7e38da8836305f017c6dbc268fd5861ff6b7e5bf [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "A Perl DBI driver for SQLite"
2DESCRIPTION = "DBD::SQLite is a Perl DBI driver for SQLite, that includes the entire \
3thing in the distribution. So in order to get a fast transaction capable \
4RDBMS working for your perl project you simply have to install this \
5module, and nothing else. \
6"
7HOMEPAGE = "https://metacpan.org/release/DBD-SQLite"
8
9SECTION = "libs"
10LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=1726e2117494ba3e13e1c3d93f795360"
12
13SRC_URI = "${CPAN_MIRROR}/authors/id/I/IS/ISHIGAKI/DBD-SQLite-${PV}.tar.gz \
14 file://sqlite-perl-test.pl \
15"
16
17SRC_URI[sha256sum] = "8994997d84b9feb4547795f78746c661fb72e3cb6a25dbdd789b731f5688a4dd"
18
19UPSTREAM_CHECK_REGEX = "DBD\-SQLite\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
20
21S = "${WORKDIR}/DBD-SQLite-${PV}"
22
23DEPENDS += "libdbi-perl-native"
24
25inherit cpan ptest-perl
26
27RDEPENDS:${PN} += "libdbi-perl \
28 sqlite3 \
29 perl-module-constant \
30 perl-module-locale \
31 perl-module-tie-hash \
32"
33
34do_install:append() {
35 if [ ${PERL_DBM_TEST} = "1" ]; then
36 install -m 755 -D ${WORKDIR}/sqlite-perl-test.pl ${D}/${bindir}/sqlite-perl-test.pl
37 fi
38}
39
40do_install_ptest() {
41 cp -r ${B}/MANIFEST ${D}${PTEST_PATH}
42 chown -R root:root ${D}${PTEST_PATH}
43}
44
45RDEPENDS:${PN}-ptest += " \
46 libtest-nowarnings-perl \
47 perl-module-lib \
48 perl-module-encode \
49 perl-module-file-spec \
50 perl-module-file-spec-functions \
51 perl-module-findbin \
52 perl-module-test-more \
53 "
54
55BBCLASSEXTEND = "native"