Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "netkit-telnet includes the telnet daemon and client." |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 2 | HOMEPAGE = "http://www.hcs.harvard.edu/~dholland/computers/netkit.html" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 3 | SECTION = "net" |
| 4 | DEPENDS = "ncurses" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 5 | LICENSE = "BSD-4-Clause" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://telnet/telnet.cc;beginline=2;endline=3;md5=780868e7b566313e70cb701560ca95ef" |
| 7 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 8 | SRC_URI = "${DEBIAN_MIRROR}/main/n/netkit-telnet/netkit-telnet_${PV}.orig.tar.gz \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 9 | file://To-aviod-buffer-overflow-in-telnet.patch \ |
| 10 | file://Warning-fix-in-the-step-of-install.patch \ |
| 11 | file://telnet-xinetd \ |
| 12 | file://cross-compile.patch \ |
| 13 | file://0001-telnet-telnetd-Fix-print-format-strings.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | file://0001-telnet-telnetd-Fix-deadlock-on-cleanup.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | file://CVE-2020-10188.patch \ |
Andrew Geissler | 748a483 | 2020-07-24 16:24:21 -0500 | [diff] [blame] | 16 | file://0001-telnetd-utility.c-Fix-buffer-overflow-in-netoprintf.patch \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 17 | file://0001-utility-Include-time.h-form-time-and-strftime-protot.patch \ |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 18 | file://0001-Drop-using-register-keyword.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 19 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 20 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/n/netkit-telnet/" |
| 22 | UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.orig\.tar" |
| 23 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 24 | EXTRA_OEMAKE = "INSTALLROOT=${D} SBINDIR=${sbindir} DAEMONMODE=755 \ |
| 25 | MANMODE=644 MANDIR=${mandir}" |
| 26 | |
| 27 | do_configure () { |
| 28 | ./configure --prefix=${prefix} |
| 29 | sed -e 's#^CFLAGS=\(.*\)$#CFLAGS= -D_GNU_SOURCE \1#' \ |
| 30 | -e 's#^CXXFLAGS=\(.*\)$#CXXFLAGS= -D_GNU_SOURCE \1#' \ |
| 31 | -e 's#^LDFLAGS=.*$#LDFLAGS= ${LDFLAGS}#' \ |
| 32 | -i MCONFIG |
| 33 | } |
| 34 | |
| 35 | do_compile () { |
| 36 | oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' SUB=telnet |
| 37 | oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' LIBS=-lutil SUB=telnetd |
| 38 | oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' SUB=telnetlogin |
| 39 | } |
| 40 | |
| 41 | do_install () { |
| 42 | install -d ${D}${bindir} |
| 43 | install -m 0755 telnet/telnet ${D}${bindir}/telnet.${PN} |
| 44 | install -d ${D}${sbindir} |
| 45 | install -d ${D}${mandir}/man1 |
| 46 | install -d ${D}${mandir}/man5 |
| 47 | install -d ${D}${mandir}/man8 |
| 48 | oe_runmake SUB=telnetd install |
| 49 | rm -rf ${D}${mandir}/man1 |
| 50 | install -D -m 4750 ${B}/telnetlogin/telnetlogin ${D}/${libdir}/telnetlogin |
| 51 | # fix up hardcoded paths |
| 52 | sed -i -e 's,/usr/sbin/,${sbindir}/,' ${WORKDIR}/telnet-xinetd |
| 53 | install -d ${D}/etc/xinetd.d/ |
| 54 | install -p -m644 ${WORKDIR}/telnet-xinetd ${D}/etc/xinetd.d/telnet |
| 55 | } |
| 56 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 57 | inherit update-alternatives |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 58 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 59 | ALTERNATIVE_PRIORITY = "100" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 60 | ALTERNATIVE:${PN} = "telnet" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 61 | ALTERNATIVE_LINK_NAME[telnet] = "${bindir}/telnet" |
| 62 | ALTERNATIVE_TARGET[telnet] = "${bindir}/telnet.${PN}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 63 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 64 | ALTERNATIVE:${PN}-doc = "telnetd.8" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 65 | ALTERNATIVE_LINK_NAME[telnetd.8] = "${mandir}/man8/telnetd.8" |
| 66 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 67 | SRC_URI[md5sum] = "d6beabaaf53fe6e382c42ce3faa05a36" |
| 68 | SRC_URI[sha256sum] = "9c80d5c7838361a328fb6b60016d503def9ce53ad3c589f3b08ff71a2bb88e00" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 69 | FILES:${PN} += "${sbindir}/in.* ${libdir}/* ${sysconfdir}/xinetd.d/*" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 70 | |
| 71 | # http://errors.yoctoproject.org/Errors/Details/186954/ |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 72 | COMPATIBLE_HOST:libc-musl = 'null' |
| 73 | RCONFLICTS:${PN} = "inetutils-telnetd" |