Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API." |
| 2 | DESCRIPTION = "lxml is a Pythonic, mature binding for the libxml2 and \ |
| 3 | libxslt libraries. It provides safe and convenient access to these \ |
| 4 | libraries using the ElementTree API. It extends the ElementTree API \ |
| 5 | significantly to offer support for XPath, RelaxNG, XML Schema, XSLT, \ |
| 6 | C14N and much more." |
| 7 | HOMEPAGE = "http://codespeak.net/lxml" |
| 8 | SECTION = "devel/python" |
| 9 | LICENSE = "BSD & GPLv2 & MIT & PSF" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | file://doc/licenses/elementtree.txt;md5=eb34d036a6e3d56314ee49a6852ac891 \ |
| 12 | file://doc/licenses/BSD.txt;md5=700a1fc17f4797d4f2d34970c8ee694b \ |
| 13 | file://doc/licenses/GPL.txt;md5=94d55d512a9ba36caa9b7df079bae19f \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | file://src/lxml/isoschematron/resources/rng/iso-schematron.rng;beginline=2;endline=7;md5=fc85684a8dd5fa272c086bceb0d99e10 \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | file://src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl;beginline=2;endline=24;md5=cc86b7b2bbc678e13f58ea403eb9929b \ |
| 16 | file://src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl;beginline=2;endline=7;md5=5b03236d293dc3784205542b409d2f53 \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | " |
| 18 | |
| 19 | DEPENDS += "libxml2 libxslt" |
| 20 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame^] | 21 | SRC_URI[md5sum] = "4d3cca9c0018dd98f39e0ac54fcc3d14" |
| 22 | SRC_URI[sha256sum] = "27ee0faf8077c7c1a589573b1450743011117f1aa1a91d5ae776bbc5ca6070f2" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 23 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame^] | 24 | inherit pypi setuptools3 |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 25 | |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame] | 26 | # {standard input}: Assembler messages: |
| 27 | # {standard input}:1488805: Error: branch out of range |
| 28 | DEBUG_OPTIMIZATION_remove_mips = " -Og" |
| 29 | DEBUG_OPTIMIZATION_append_mips = " -O" |
| 30 | BUILD_OPTIMIZATION_remove_mips = " -Og" |
| 31 | BUILD_OPTIMIZATION_append_mips = " -O" |
| 32 | |
| 33 | DEBUG_OPTIMIZATION_remove_mipsel = " -Og" |
| 34 | DEBUG_OPTIMIZATION_append_mipsel = " -O" |
| 35 | BUILD_OPTIMIZATION_remove_mipsel = " -Og" |
| 36 | BUILD_OPTIMIZATION_append_mipsel = " -O" |
| 37 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 38 | BBCLASSEXTEND = "native nativesdk" |
| 39 | |
| 40 | RDEPENDS_${PN} += "libxml2 libxslt ${PYTHON_PN}-compression" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame^] | 41 | |
| 42 | CLEANBROKEN = "1" |