Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Library for developers to extract data from Microsoft Excel (tm) spreadsheet files" |
| 2 | DESCRIPTION = "Extract data from Excel spreadsheets (.xls and .xlsx,\ |
| 3 | versions 2.0 onwards) on any platform. Pure Python (2.6, 2.7, 3.2+). \ |
| 4 | Strong support for Excel dates. Unicode-aware." |
| 5 | HOMEPAGE = "http://www.python-excel.org/" |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=5f4244d51fcc1e7cc2d43e96891b2f80" |
| 8 | |
| 9 | SRC_URI[md5sum] = "e5d5b96924d791b22898b622eb3e918e" |
| 10 | SRC_URI[sha256sum] = "546eb36cee8db40c3eaa46c351e67ffee6eeb5fa2650b71bc4c758a29a1b29b2" |
| 11 | |
| 12 | SRC_URI += " \ |
| 13 | file://run-ptest \ |
| 14 | " |
| 15 | |
| 16 | inherit ptest pypi setuptools3 |
| 17 | |
| 18 | RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell" |
| 19 | |
| 20 | RDEPENDS_${PN}-ptest += " \ |
| 21 | ${PYTHON_PN}-pytest \ |
| 22 | " |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | install -d ${D}${PTEST_PATH}/tests |
| 26 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 27 | install -d ${D}${PTEST_PATH}/examples |
| 28 | cp -rf ${S}/examples/* ${D}${PTEST_PATH}/examples/ |
| 29 | } |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |