Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet." |
| 2 | SECTION = "devel/python" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5a8d76283514a1b7e6a414aba38629b5" |
| 5 | |
| 6 | SRC_URI[md5sum] = "ce9cbbcc89620fd47a2468badd08dcf0" |
| 7 | SRC_URI[sha256sum] = "8b6b1afe7731d7d9cbb0398b4a811ebb5e6be5c174f72c68abf81f919a435de9" |
| 8 | |
| 9 | SRC_URI += " \ |
| 10 | file://run-ptest \ |
| 11 | " |
| 12 | |
| 13 | inherit pypi setuptools3 ptest |
| 14 | |
| 15 | RDEPENDS_${PN}-ptest += " \ |
| 16 | ${PYTHON_PN}-pytest \ |
| 17 | " |
| 18 | |
| 19 | do_install_ptest() { |
| 20 | install -d ${D}${PTEST_PATH}/tests |
| 21 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 22 | } |