Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Keyboard configuration database for X Window" |
| 2 | |
| 3 | DESCRIPTION = "The non-arch keyboard configuration database for X \ |
| 4 | Window. The goal is to provide the consistent, well-structured, \ |
| 5 | frequently released open source of X keyboard configuration data for X \ |
| 6 | Window System implementations. The project is targeted to XKB-based \ |
| 7 | systems." |
| 8 | |
| 9 | HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig" |
| 10 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config" |
| 11 | |
| 12 | LICENSE = "MIT & MIT-style" |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9" |
| 14 | |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 15 | SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2 \ |
| 16 | file://0001-fix-python3-support.patch \ |
| 17 | " |
| 18 | SRC_URI[md5sum] = "b5980bdc6c7d79f6dcccba8c76bb6c5d" |
| 19 | SRC_URI[sha256sum] = "1d4175278bf06000683656763a8b1d3282c61a314b6db41260c8efe92d621802" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | |
| 21 | SECTION = "x11/libs" |
| 22 | DEPENDS = "util-macros libxslt-native" |
| 23 | |
| 24 | EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps" |
| 25 | |
| 26 | FILES_${PN} += "${datadir}/X11/xkb" |
| 27 | |
| 28 | inherit autotools pkgconfig gettext |
| 29 | |
| 30 | do_install_append () { |
| 31 | install -d ${D}${datadir}/X11/xkb/compiled |
| 32 | cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg |
| 33 | } |