Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "SysV init scripts which are only used in an LSB image" |
| 2 | HOMEPAGE = "https://wiki.debian.org/LSBInitScripts" |
| 3 | SECTION = "base" |
| 4 | LICENSE = "GPLv2" |
| 5 | DEPENDS = "popt glib-2.0" |
| 6 | |
| 7 | RPROVIDES_${PN} += "initd-functions" |
| 8 | RDEPENDS_${PN} += "util-linux" |
| 9 | RCONFLICTS_${PN} = "initscripts-functions" |
| 10 | |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=ebf4e8b49780ab187d51bd26aaa022c6" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | SRC_URI = "git://github.com/fedora-sysv/initscripts \ |
| 15 | file://functions.patch \ |
| 16 | file://0001-functions-avoid-exit-1-which-causes-init-scripts-to-.patch \ |
| 17 | " |
| 18 | SRCREV = "a51c1b4f7dcf55b568b2ee4c2b18078849943469" |
| 19 | UPSTREAM_CHECK_GITTAGREGEX = "^(?P<pver>\d+(\.\d+)+)" |
| 20 | |
| 21 | SRC_URI[md5sum] = "d6c798f40dceb117e12126d94cb25a9a" |
| 22 | SRC_URI[sha256sum] = "1793677bdd1f7ee4cb00878ce43346196374f848a4c8e4559e086040fc7487db" |
| 23 | |
| 24 | # Since we are only taking the patched version of functions, no need to |
| 25 | # configure or compile anything so do not execute these |
| 26 | do_configure[noexec] = "1" |
| 27 | do_compile[noexec] = "1" |
| 28 | |
| 29 | do_install(){ |
| 30 | install -d ${D}${sysconfdir}/init.d/ |
| 31 | install -m 0644 ${S}/rc.d/init.d/functions ${D}${sysconfdir}/init.d/functions |
| 32 | } |