Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Extremely Fast Compression algorithm" |
| 2 | DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems." |
| 3 | |
| 4 | LICENSE = "BSD | BSD-2-Clause | GPL-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=ebc2ea4814a64de7708f1571904b32cc\ |
| 6 | file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 7 | file://LICENSE;md5=7f2857d58beff6d04137bf9b09e5ffb6" |
| 8 | |
| 9 | PE = "1" |
| 10 | |
| 11 | SRCREV = "7bb64ff2b69a9f8367de9ab483cdadf42b4c1b65" |
| 12 | |
| 13 | SRC_URI = "git://github.com/lz4/lz4.git \ |
| 14 | file://0001-tests-Makefile-don-t-use-LIBDIR-as-variable.patch \ |
| 15 | file://run-ptest \ |
| 16 | " |
| 17 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}" |
| 22 | |
| 23 | do_install() { |
| 24 | oe_runmake install |
| 25 | } |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |