Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "File type identification using libmagic" |
| 2 | DESCRIPTION = "This module uses ctypes to access the libmagic file type \ |
| 3 | identification library. It makes use of the local magic database and supports \ |
| 4 | both textual and MIME-type output." |
| 5 | HOMEPAGE = "http://github.com/ahupp/python-magic" |
| 6 | |
| 7 | LICENSE = "MIT" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=16a934f165e8c3245f241e77d401bb88" |
| 9 | |
| 10 | PYPI_PACKAGE = "python-magic" |
| 11 | |
| 12 | inherit pypi setuptools3 |
| 13 | |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 14 | SRC_URI[md5sum] = "5edc6caa39cc62641850f6b1b6f284ba" |
| 15 | SRC_URI[sha256sum] = "b757db2a5289ea3f1ced9e60f072965243ea43a2221430048fd8cacab17be0ce" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 17 | RDEPENDS_${PN} += "file \ |
| 18 | ${PYTHON_PN}-ctypes \ |
| 19 | ${PYTHON_PN}-io \ |
| 20 | ${PYTHON_PN}-shell" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | |
| 22 | BBCLASSEXTEND = "native" |