Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 1 | DESCRIPTION = "VCR imitation for python requests" |
| 2 | HOMEPAGE = "https://github.com/betamaxpy/betamax" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=61c15f0c146c5fb1a8ce8ba2f310d73c" |
| 5 | |
| 6 | SRC_URI += " \ |
| 7 | file://run-ptest \ |
| 8 | " |
| 9 | |
| 10 | SRC_URI[md5sum] = "b8182d43a200fc126a3bf7555626f964" |
| 11 | SRC_URI[sha256sum] = "5bf004ceffccae881213fb722f34517166b84a34919b92ffc14d1dbd050b71c2" |
| 12 | |
| 13 | inherit pypi setuptools3 ptest |
| 14 | |
| 15 | RDEPENDS_${PN}-ptest += " \ |
| 16 | ${PYTHON_PN}-pytest \ |
| 17 | ${PYTHON_PN}-requests \ |
| 18 | " |
| 19 | |
| 20 | do_install_ptest() { |
| 21 | install -d ${D}${PTEST_PATH}/tests |
| 22 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 23 | } |