Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "A generic, spec-compliant, thorough implementation of the OAuth request-signing logic" |
| 2 | HOMEPAGE = "https://github.com/idan/oauthlib" |
| 3 | |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 4 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=abd2675e944a2011aed7e505290ba482" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 7 | SRC_URI[md5sum] = "43cb2b5bac983712ee55076b61181cc2" |
| 8 | SRC_URI[sha256sum] = "bee41cc35fcca6e988463cacc3bcb8a96224f470ca547e697b604cc697b2f889" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 9 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 10 | inherit pypi setuptools3 |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | |
| 12 | # The following configs & dependencies are from setuptools extras_require. |
| 13 | # These dependencies are optional, hence can be controlled via PACKAGECONFIG. |
| 14 | # The upstream names may not correspond exactly to bitbake package names. |
| 15 | # |
| 16 | # Uncomment this line to enable all the optional features. |
| 17 | #PACKAGECONFIG ?= "test signedtoken signals rsa" |
| 18 | PACKAGECONFIG[test] = ",,,${PYTHON_PN}-blinker ${PYTHON_PN}-cryptography ${PYTHON_PN}-nose ${PYTHON_PN}-pyjwt" |
| 19 | PACKAGECONFIG[signedtoken] = ",,,${PYTHON_PN}-cryptography ${PYTHON_PN}-pyjwt" |
| 20 | PACKAGECONFIG[signals] = ",,,${PYTHON_PN}-blinker" |
| 21 | PACKAGECONFIG[rsa] = ",,,${PYTHON_PN}-cryptography" |
| 22 | |
| 23 | RDEPENDS_${PN} += "${PYTHON_PN}-core ${PYTHON_PN}-crypt ${PYTHON_PN}-datetime ${PYTHON_PN}-json ${PYTHON_PN}-logging ${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-unittest" |