blob: 84397b65bdc0f61efb486ec9452360e737fa88d3 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A pure Python netlink and Linux network configuration library"
2LICENSE = "GPLv2 & Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
4 file://LICENSE.Apache.v2;md5=34281e312165f843a2b7d1f114fe65ce"
5
Andrew Geisslerd688a012020-09-18 13:36:00 -05006SRC_URI[md5sum] = "6bde3624a6f22bdfb630bb54243a0d1d"
7SRC_URI[sha256sum] = "774c5ecf05fe40f0f601a7ab33c19ca0b24f00bf4a094e58deaa5333b7ca49b5"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
9inherit setuptools3 pypi ptest
10
11RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-ctypes \
13 ${PYTHON_PN}-distutils \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-json \
16 ${PYTHON_PN}-logging \
17 ${PYTHON_PN}-multiprocessing \
18 ${PYTHON_PN}-pickle \
19 ${PYTHON_PN}-pkgutil \
20 ${PYTHON_PN}-pprint \
21 ${PYTHON_PN}-shell \
22 ${PYTHON_PN}-unixadmin \
23"
24
25SRC_URI += " \
26 file://run-ptest \
27"
28
29RDEPENDS_${PN}-ptest += " \
30 ${PYTHON_PN}-pytest \
31 ${PYTHON_PN}-fcntl \
32"
33
34do_install_ptest() {
35 install -d ${D}${PTEST_PATH}/tests
36 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
37}