Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "World timezone definitions, modern and historical" |
| 2 | HOMEPAGE = "http://pythonhosted.org/pytz" |
| 3 | LICENSE = "MIT" |
Andrew Geissler | 748a483 | 2020-07-24 16:24:21 -0500 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 5 | |
| 6 | inherit pypi setuptools3 ptest |
| 7 | |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 8 | SRC_URI[md5sum] = "8c849bdf95414fe708a84473e42d4406" |
| 9 | SRC_URI[sha256sum] = "83a4a90894bf38e243cf052c8b58f381bfe9a7a483f6a9cab140bc7f702ac4da" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
| 11 | RDEPENDS_${PN}_class-target += "\ |
| 12 | ${PYTHON_PN}-datetime \ |
| 13 | ${PYTHON_PN}-doctest \ |
| 14 | ${PYTHON_PN}-io \ |
| 15 | ${PYTHON_PN}-pickle \ |
| 16 | ${PYTHON_PN}-pprint \ |
| 17 | ${PYTHON_PN}-threading \ |
| 18 | " |
| 19 | |
| 20 | BBCLASSEXTEND = "native nativesdk" |
| 21 | |
| 22 | SRC_URI += " \ |
| 23 | file://run-ptest \ |
| 24 | " |
| 25 | |
| 26 | RDEPENDS_${PN}-ptest += " \ |
| 27 | ${PYTHON_PN}-pytest \ |
| 28 | " |
| 29 | |
| 30 | do_install_ptest() { |
| 31 | install -d ${D}${PTEST_PATH}/pytz |
| 32 | install -d ${D}${PTEST_PATH}/pytz/tests |
| 33 | cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/ |
Andrew Geissler | 748a483 | 2020-07-24 16:24:21 -0500 | [diff] [blame] | 34 | cp -f ${S}/README.rst ${D}${PTEST_PATH}/ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | |
| 36 | } |