Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Userspace RCU (read-copy-update) library" |
| 2 | DESCRIPTION = "A userspace RCU (read-copy-update) library. This data \ |
| 3 | synchronization library provides read-side access which scales linearly \ |
| 4 | with the number of cores. " |
| 5 | HOMEPAGE = "http://lttng.org/urcu" |
| 6 | BUGTRACKER = "http://lttng.org/project/issues" |
| 7 | |
| 8 | LICENSE = "LGPL-2.1-or-later & MIT" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e548d28737289d75a8f1e01ba2fd7825 \ |
| 10 | file://include/urcu/urcu.h;beginline=4;endline=32;md5=4de0d68d3a997643715036d2209ae1d9 \ |
| 11 | file://include/urcu/uatomic/x86.h;beginline=4;endline=21;md5=58e50bbd8a2f073bb5500e6554af0d0b" |
| 12 | |
| 13 | SRC_URI = "http://lttng.org/files/urcu/userspace-rcu-${PV}.tar.bz2" |
| 14 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "ca43bf261d4d392cff20dfae440836603bf009fce24fdc9b2697d837a2239d4f" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/userspace-rcu-${PV}" |
| 18 | inherit autotools multilib_header |
| 19 | |
| 20 | CPPFLAGS:append:riscv64 = " -pthread -D_REENTRANT" |
| 21 | |
| 22 | do_install:append() { |
| 23 | oe_multilib_header urcu/config.h |
| 24 | } |