blob: 8f622bf6f888891b10be1c397de6a5fa9ae9fde9 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Delivery framework for general Input Method configuration"
2DESCRIPTION = "IMSettings is a framework that delivers Input Method \
3settings and applies the changes so they take effect \
4immediately without any need to restart applications \
5or the desktop. \
6This package contains the core DBus services and some utilities."
7HOMEPAGE = "http://code.google.com/p/imsettings/"
8SECTION = "Applications/System"
9
10inherit autotools gtk-doc gobject-introspection distro_features_check
11
12REQUIRED_DISTRO_FEATURES = "x11"
13
14SRC_URI = "https://bitbucket.org/tagoh/imsettings/downloads/${BPN}-${PV}.tar.bz2 \
15 "
16
17SRC_URI[md5sum] = "c6c65a2b2654fe9dfe9ab2e8b80c079a"
18SRC_URI[sha256sum] = "196d3a74cef254ff812c32682d1818d740e36a68b976fef9e99748d23a71a71a"
19
20LICENSE = "LGPLv2+"
21LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
22
23EXTRA_OECONF = "--with-xinputsh=50-xinput.sh \
24 --disable-static \
25 "
26
27DEPENDS = "gtk+ gconf libnotify dbus-glib libgxim xfconf intltool-native"
28
29RDEPENDS_${PN} += "bash"
30
31FILES_${PN} += "${datadir}/dbus-1/* ${datadir}/gir-1.0/* ${libdir}/girepository-1.0/*"