William A. Kennington III | 49e9566 | 2021-09-15 16:19:36 -0700 | [diff] [blame] | 1 | SUMMARY = "Open source Python library for rapid development of applications \ |
| 2 | that make use of innovative user interfaces, such as multi-touch apps." |
| 3 | HOMEPAGE = "https://kivy.org/" |
| 4 | LICENSE = "MIT" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=22e7b4dd8140eec57fd7edfd9fa23dfc" |
William A. Kennington III | 49e9566 | 2021-09-15 16:19:36 -0700 | [diff] [blame] | 6 | |
| 7 | inherit setuptools3 pkgconfig features_check |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 8 | PIP_INSTALL_PACKAGE = "Kivy" |
William A. Kennington III | 49e9566 | 2021-09-15 16:19:36 -0700 | [diff] [blame] | 9 | |
| 10 | SRC_URI = "\ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | git://github.com/kivy/kivy.git;protocol=https;branch=master \ |
William A. Kennington III | 49e9566 | 2021-09-15 16:19:36 -0700 | [diff] [blame] | 12 | " |
| 13 | |
| 14 | # Kivy's setup files only look for GLES libraries for Android, iOS, RPi, |
| 15 | # and mali-based OS's. We need to patch the setup file to tell Kivy setup |
| 16 | # that our machine has GLES libaries installed as well |
| 17 | # Also, if using SDL2 as backend, SDL2 needs to be configured wth gles |
| 18 | SRC_URI += " \ |
| 19 | file://0001-add-support-for-glesv2.patch \ |
| 20 | " |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 21 | SRCREV = "960b95dc666753f59eff1b449124490fbec10184" |
William A. Kennington III | 49e9566 | 2021-09-15 16:19:36 -0700 | [diff] [blame] | 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | PACKAGES += "${PN}-examples" |
| 26 | FILES:${PN}-examples = "/usr/share/kivy-examples" |
| 27 | |
| 28 | USE_WAYLAND = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '1', '0', d)}" |
| 29 | export USE_WAYLAND |
| 30 | |
| 31 | # if using Wayland, let's use pure Wayland (and not XWayland) |
| 32 | # so do not build using X11 flag when we detect Wayland |
| 33 | USE_X11 = " \ |
| 34 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '0', \ |
| 35 | bb.utils.contains('DISTRO_FEATURES', 'x11', '1', \ |
| 36 | '0', d), d)}" |
| 37 | export USE_X11 |
| 38 | |
| 39 | # Use OpenGL ES 2.0 library |
| 40 | KIVY_GRAPHICS = "gles" |
| 41 | export KIVY_GRAPHICS |
| 42 | |
| 43 | KIVY_CROSS_SYSROOT="${RECIPE_SYSROOT}" |
| 44 | export KIVY_CROSS_SYSROOT |
| 45 | |
| 46 | REQUIRED_DISTRO_FEATURES += "x11 opengl" |
| 47 | |
| 48 | DEPENDS += " \ |
| 49 | gstreamer1.0 \ |
| 50 | gstreamer1.0-python \ |
| 51 | libsdl2 \ |
| 52 | libsdl2-ttf \ |
| 53 | libsdl2-image \ |
| 54 | libsdl2-mixer \ |
| 55 | pango \ |
| 56 | python3 \ |
| 57 | python3-cython-native \ |
| 58 | " |
| 59 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 60 | RDEPENDS:${PN} = " \ |
William A. Kennington III | 49e9566 | 2021-09-15 16:19:36 -0700 | [diff] [blame] | 61 | gstreamer1.0 \ |
| 62 | gstreamer1.0-python \ |
| 63 | libsdl2 \ |
| 64 | libsdl2-ttf \ |
| 65 | libsdl2-image \ |
| 66 | libsdl2-mixer \ |
| 67 | pango \ |
| 68 | python3 \ |
| 69 | python3-docutils \ |
| 70 | python3-fcntl \ |
| 71 | python3-image \ |
| 72 | python3-pillow \ |
| 73 | python3-pygments \ |
| 74 | " |