Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Setuptools Rust extension plugin" |
| 2 | DESCRIPTION = "setuptools-rust is a plugin for setuptools to build Rust \ |
| 3 | Python extensions implemented with PyO3 or rust-cpython.\ |
| 4 | \ |
| 5 | Compile and distribute Python extensions written in Rust as easily as if they were written in C." |
| 6 | HOMEPAGE = "https://github.com/PyO3/setuptools-rust" |
| 7 | BUGTRACKER = "https://github.com/PyO3/setuptools-rust/issues" |
| 8 | |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5" |
| 11 | |
| 12 | SRC_URI = "${PYPI_SRC_URI} \ |
| 13 | https://files.pythonhosted.org/packages/67/08/e1aa2c582c62ac76e4d60f8e454bd3bba933781a06a88b4e38797445822a/setuptools-rust-${PV}.tar.gz \ |
| 14 | " |
| 15 | SRC_URI[sha256sum] = "94b1dd5d5308b3138d5b933c3a2b55e6d6927d1a22632e509fcea9ddd0f7e486" |
| 16 | |
| 17 | inherit cargo pypi python_setuptools_build_meta |
| 18 | |
| 19 | DEPENDS += "python3-setuptools-scm-native python3-wheel-native" |
| 20 | # remove when https://github.com/PyO3/setuptools-rust/commit/7ced8d2a8f36e1b4fc41b5544636defb7bd44bdf |
| 21 | # is included |
| 22 | DEPENDS += "python3-semantic-version-native" |
| 23 | |
| 24 | RDEPENDS:${PN} += " \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 25 | python3-json \ |
| 26 | python3-semantic-version \ |
| 27 | python3-setuptools \ |
| 28 | python3-setuptools-scm \ |
| 29 | python3-shell \ |
| 30 | python3-toml \ |
| 31 | python3-typing-extensions \ |
| 32 | python3-wheel \ |
| 33 | " |
| 34 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 35 | BBCLASSEXTEND = "native nativesdk" |