Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Makes working with XML feel like you are working with JSON" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://github.com/martinblech/xmltodict" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=01441d50dc74476db58a41ac10cb9fa2" |
| 5 | |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "341595a488e3e01a85a9d8911d8912fd922ede5fecc4dce437eb4b6c8d037e56" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 7 | |
| 8 | PYPI_PACKAGE = "xmltodict" |
| 9 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 10 | BBCLASSEXTEND = "native nativesdk" |
| 11 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | inherit pypi setuptools3 ptest |
| 13 | |
| 14 | SRC_URI += " \ |
| 15 | file://run-ptest \ |
| 16 | " |
| 17 | |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 18 | RDEPENDS:${PN} += " \ |
| 19 | ${PYTHON_PN}-core \ |
| 20 | ${PYTHON_PN}-xml \ |
| 21 | ${PYTHON_PN}-io \ |
| 22 | " |
| 23 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 24 | RDEPENDS:${PN}-ptest += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 25 | ${PYTHON_PN}-pytest \ |
| 26 | " |
| 27 | |
| 28 | do_install_ptest() { |
| 29 | install -d ${D}${PTEST_PATH}/tests |
| 30 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 31 | } |