blob: 495e7c4a836e42e662563406b883d88248364800 [file] [log] [blame]
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -05001SUMMARY = "OpenPower Software Management"
2DESCRIPTION = "OpenPower Software Manager provides a set of host software \
3management daemons. It is suitable for use on a wide variety of OpenPower \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/openpower-pnor-code-mgmt"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10inherit autotools pkgconfig
11inherit obmc-phosphor-dbus-service
12
13DEPENDS += " \
14 autoconf-archive-native \
15 phosphor-dbus-interfaces \
16 phosphor-logging \
17 sdbusplus \
18 "
19
20RDEPENDS_${PN} += " \
21 mtd-utils-ubifs \
22 phosphor-dbus-interfaces \
23 phosphor-logging \
24 sdbusplus \
25 "
26
Adriana Kobylak2e950822017-06-02 09:22:40 -050027S = "${WORKDIR}/git"
28
29SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
30
Adriana Kobylak69d3de02017-05-25 15:48:27 -050031SRC_URI += " \
32 file://bios-ubiattach \
33 file://bios-ubiformat"
34
Patrick Williams8c259762017-06-30 14:30:04 -050035SRCREV = "cb9df4ed49e559a914faaafeafd8bbb1491cc57f"
Adriana Kobylak2e950822017-06-02 09:22:40 -050036
37do_install_append() {
Adriana Kobylak69d3de02017-05-25 15:48:27 -050038 install -d ${D}${sbindir}
39 install -m 0755 ${WORKDIR}/bios-ubiattach ${D}${sbindir}/bios-ubiattach
40 install -m 0755 ${WORKDIR}/bios-ubiformat ${D}${sbindir}/bios-ubiformat
41}
42
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050043DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
Adriana Kobylak2e950822017-06-02 09:22:40 -050044
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050045SYSTEMD_SERVICE_${PN} += " \
46 obmc-flash-bios-ubiattach.service \
47 obmc-flash-bios-ubimount@.service \
Adriana Kobylak7f01f212017-05-22 14:41:02 -050048 obmc-flash-bios-ubiumount-prsv.service \
49 obmc-flash-bios-ubiumount-rw@.service \
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050050 obmc-flash-bios-squashfsmount@.service \
51 "