Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 1 | SUMMARY = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications." |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | HOMEPAGE = "https://www.khronos.org/vulkan/" |
| 3 | BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 4 | LICENSE = "Apache-2.0" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a" |
| 7 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 8 | SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git;branch=main;protocol=https;lfs=0 \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 9 | file://0001-vulkan-samples-Fix-reproducibility-issue.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 10 | file://0001-Do-not-use-LFS64-functions-on-linux-musl.patch;patchdir=third_party/spdlog \ |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 11 | file://0001-Deprecate-u8string_view.patch;patchdir=third_party/spdlog \ |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 12 | file://32bit.patch \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 13 | " |
| 14 | |
| 15 | UPSTREAM_CHECK_COMMITS = "1" |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 16 | SRCREV = "2307c3eb5608cb1205fa3514b3a31dbfb857d00c" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 17 | |
| 18 | UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for" |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | REQUIRED_DISTRO_FEATURES = 'vulkan' |
| 22 | |
| 23 | inherit cmake features_check |
| 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | FILES:${PN} += "${datadir}" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 26 | |
| 27 | # |
| 28 | # There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths |
| 29 | # used for logging with LOGE in the code. We need to make this match the value we use |
| 30 | # in the debug source remapping from CFLAGS |
| 31 | # |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 32 | EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=${TARGET_DBGSRC_DIR}/" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 33 | # Binaries built with PCH enabled don't appear reproducible, differing results were seen |
| 34 | # from some builds depending on the point the PCH was compiled. Disable it to be |
| 35 | # deterministic |
| 36 | EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | |
| 38 | # This needs to be specified explicitly to avoid xcb/xlib dependencies |
| 39 | EXTRA_OECMAKE += "-DVKB_WSI_SELECTION=D2D" |