Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "KC705 Pre-built Bitstream" |
| 2 | DESCRIPTION = "A Pre-built bitstream for the KC705, which is capable of booting a Linux system." |
| 3 | HOMEPAGE = "http://www.xilinx.com" |
| 4 | SECTION = "bsp" |
| 5 | |
| 6 | # The BSP package does not include any license information. |
| 7 | LICENSE = "Proprietary" |
| 8 | LICENSE_FLAGS = "xilinx" |
| 9 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28" |
| 10 | |
| 11 | COMPATIBLE_MACHINE = "kc705-microblazeel" |
| 12 | |
| 13 | inherit deploy |
| 14 | inherit xilinx-fetch-restricted |
| 15 | |
| 16 | BSP_NAME = "xilinx-kc705" |
| 17 | BSP_FILE = "${BSP_NAME}-v${PV}-final.bsp" |
| 18 | SRC_URI = "https://www.xilinx.com/member/forms/download/xef.html?filename=${BSP_FILE};downloadfilename=${BSP_FILE}" |
| 19 | SRC_URI[md5sum] = "5c0365a8a26cc27b4419aa1d7dd82351" |
| 20 | SRC_URI[sha256sum] = "a909a91a37a9925ee2f972ccb10f986a26ff9785c1a71a483545a192783bf773" |
| 21 | |
| 22 | PROVIDES = "virtual/bitstream" |
| 23 | |
| 24 | FILES_${PN} += "/boot/download.bit" |
| 25 | |
| 26 | INHIBIT_DEFAULT_DEPS = "1" |
| 27 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 28 | |
| 29 | # deps needed to extract content from the .bsp file |
| 30 | DEPENDS += "tar-native gzip-native" |
| 31 | |
| 32 | do_compile() { |
| 33 | # Extract the bitstream into workdir |
| 34 | tar -xf ${WORKDIR}/${BSP_FILE} ${BSP_NAME}-axi-full-${PV}/pre-built/linux/images/download.bit -C ${S} |
| 35 | # move the bit file to ${S}/ as it is in a subdir in the tar file |
| 36 | for i in $(find -type f -name download.bit); do mv $i ${S}; done |
| 37 | } |
| 38 | |
| 39 | do_install() { |
| 40 | install -D ${S}/download.bit ${D}/boot/download.bit |
| 41 | } |
| 42 | |
| 43 | do_deploy () { |
| 44 | install -D ${S}/download.bit ${DEPLOYDIR}/download.bit |
| 45 | } |
| 46 | |
| 47 | addtask deploy before do_build after do_install |
| 48 | |