Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Module::Build::Tiny - A tiny replacement for Module::Build" |
| 2 | DESCRIPTION = "Many Perl distributions use a Build.PL file instead of a \ |
| 3 | Makefile.PL file to drive distribution configuration, build, test and \ |
| 4 | installation. Traditionally, Build.PL uses Module::Build as the underlying \ |
| 5 | build system. This module provides a simple, lightweight, drop-in replacement. \ |
| 6 | Whereas Module::Build has over 6,700 lines of code; this module has less than \ |
| 7 | 120, yet supports the features needed by most distributions." |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | HOMEPAGE = "http://search.cpan.org/~leont/Module-Build-Tiny/" |
| 11 | |
| 12 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| 13 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2b9e8b5e2bd19fcc97ac84b78a271a64" |
| 14 | |
| 15 | DEPENDS = "libextutils-config-perl-native libextutils-helpers-perl-native libextutils-installpaths-perl-native" |
| 16 | |
| 17 | SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Module-Build-Tiny-${PV}.tar.gz" |
| 18 | SRC_URI[sha256sum] = "71260e9421b93c33dd1b3e7d0cf15f759c0ca7c753fa840279ec3be70f8f8c9d" |
| 19 | |
| 20 | S = "${WORKDIR}/Module-Build-Tiny-${PV}" |
| 21 | |
| 22 | inherit cpan_build ptest-perl |
| 23 | |
| 24 | RDEPENDS:${PN} += " \ |
| 25 | libextutils-config-perl \ |
| 26 | libextutils-helpers-perl \ |
| 27 | libextutils-installpaths-perl \ |
| 28 | perl-module-carp \ |
| 29 | perl-module-cpan \ |
| 30 | perl-module-data-dumper \ |
| 31 | perl-module-encode-encoding \ |
| 32 | perl-module-exporter \ |
| 33 | perl-module-extutils-cbuilder \ |
| 34 | perl-module-extutils-cbuilder-base \ |
| 35 | perl-module-extutils-install \ |
| 36 | perl-module-extutils-makemaker \ |
| 37 | perl-module-extutils-parsexs \ |
| 38 | perl-module-file-path \ |
| 39 | perl-module-file-spec \ |
| 40 | perl-module-file-temp \ |
| 41 | perl-module-getopt-long \ |
| 42 | perl-module-io-handle \ |
| 43 | perl-module-ipc-cmd \ |
| 44 | perl-module-json-pp \ |
| 45 | perl-module-load \ |
| 46 | perl-module-metadata \ |
| 47 | perl-module-parse-cpan-meta \ |
| 48 | perl-module-perl-ostype \ |
| 49 | perl-module-pod-man \ |
| 50 | perl-module-tap-harness-env \ |
| 51 | perl-module-test-more \ |
| 52 | perl-module-text-parsewords \ |
| 53 | perl-module-xsloader \ |
| 54 | " |
| 55 | |
| 56 | RDEPENDS:${PN}-ptest += " \ |
| 57 | packagegroup-core-buildessential \ |
| 58 | perl-dev \ |
| 59 | perl-module-blib \ |
| 60 | perl-module-ipc-open2 \ |
| 61 | " |
| 62 | |
| 63 | INSANE_SKIP:${PN}-ptest += "dev-deps" |
| 64 | |
| 65 | BBCLASSEXTEND = "native" |