Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Fast Log processor and Forwarder" |
| 2 | DESCRIPTION = "Fluent Bit is a data collector, processor and \ |
| 3 | forwarder for Linux. It supports several input sources and \ |
| 4 | backends (destinations) for your data. \ |
| 5 | " |
| 6 | |
| 7 | HOMEPAGE = "http://fluentbit.io" |
| 8 | BUGTRACKER = "https://github.com/fluent/fluent-bit/issues" |
| 9 | |
| 10 | LICENSE = "Apache-2.0" |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93" |
| 12 | SECTION = "net" |
| 13 | |
| 14 | SRC_URI = "http://fluentbit.io/releases/1.3/fluent-bit-${PV}.tar.gz \ |
| 15 | file://jemalloc.patch \ |
| 16 | file://cross-build-init-system-detection.patch \ |
| 17 | file://builtin-nan.patch \ |
Brad Bishop | 0e2770c | 2020-01-21 07:31:46 -0500 | [diff] [blame] | 18 | file://0001-ppc-Fix-signature-for-co_create-API.patch \ |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 19 | file://0001-bin-fix-SIGSEGV-caused-by-using-flb_free-instead-of-.patch \ |
| 20 | file://0002-parser-Fix-SIGSEGV-caused-by-using-flb_free-instead-.patch \ |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 21 | file://0001-Control-sytemd-unit-install-location-with-SYSTEM_DIR.patch \ |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 22 | " |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 23 | SRC_URI[md5sum] = "6eae6dfd0a874e5dd270c36e9c68f747" |
| 24 | SRC_URI[sha256sum] = "e037c76c89269c8dc4027a08e442fefd2751b0f1e0f9c38f9a4b12d781a9c789" |
| 25 | |
| 26 | S = "${WORKDIR}/fluent-bit-${PV}" |
| 27 | DEPENDS = "zlib bison-native flex-native" |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 28 | DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | DEPENDS:append:libc-musl = " fts " |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | INSANE_SKIP:${PN}-dev += "dev-elf" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 33 | |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 34 | LTO = "" |
| 35 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 36 | # Use CMake 'Unix Makefiles' generator |
| 37 | OECMAKE_GENERATOR ?= "Unix Makefiles" |
| 38 | |
| 39 | # Fluent Bit build options |
| 40 | # ======================== |
| 41 | |
| 42 | # Host related setup |
| 43 | EXTRA_OECMAKE += "-DGNU_HOST=${HOST_SYS} -DFLB_ALL=ON -DFLB_TD=1" |
| 44 | |
| 45 | # Disable LuaJIT and filter_lua support |
| 46 | EXTRA_OECMAKE += "-DFLB_LUAJIT=Off -DFLB_FILTER_LUA=Off " |
| 47 | |
| 48 | # Disable Library and examples |
| 49 | EXTRA_OECMAKE += "-DFLB_SHARED_LIB=Off -DFLB_EXAMPLES=Off " |
| 50 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 51 | # Enable systemd iff systemd is in DISTRO_FEATURES |
| 52 | EXTRA_OECMAKE += "${@bb.utils.contains('DISTRO_FEATURES','systemd','-DFLB_SYSTEMD=On -DSYSTEMD_DIR=${systemd_system_unitdir}','-DFLB_SYSTEMD=Off',d)}" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 53 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 54 | EXTRA_OECMAKE:append:riscv64 = " -DFLB_DEPS='atomic'" |
| 55 | EXTRA_OECMAKE:append:riscv32 = " -DFLB_DEPS='atomic'" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 56 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 57 | # Kafka Output plugin (disabled by default): note that when |
| 58 | # enabling Kafka output plugin, the backend library librdkafka |
| 59 | # requires 'openssl' as a dependency. |
| 60 | # |
| 61 | # DEPENDS += "openssl " |
| 62 | # EXTRA_OECMAKE += "-DFLB_OUT_KAFKA=On " |
| 63 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 64 | inherit cmake systemd |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 65 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 66 | CFLAGS += "-fcommon" |
| 67 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 68 | SYSTEMD_SERVICE:${PN} = "td-agent-bit.service" |
| 69 | TARGET_CC_ARCH:append = " ${SELECTED_OPTIMIZATION}" |