blob: cd14b485089008569f80c8cbdb1bb268b45a143d [file] [log] [blame]
Patrick Williams7784c422022-11-17 07:29:11 -06001SUMMARY = "GNOME Online Accounts - Single sign-on framework for GNOME"
2LICENSE = "LGPL-2.0-or-later"
3LIC_FILES_CHKSUM = "file://COPYING;md5=34c88b124db5fb2762c1676be7dadd36"
4
5GNOMEBASEBUILDCLASS = "meson"
6
7inherit gnomebase gsettings gobject-introspection gtk-icon-cache vala features_check
8
Patrick Williams8e7b46e2023-05-01 14:19:06 -05009DEPENDS = "gdk-pixbuf dbus glib-2.0"
Patrick Williams7784c422022-11-17 07:29:11 -060010
Patrick Williamsb542dec2023-06-09 01:26:37 -050011SRC_URI += "file://0001-Replace-filename-with-basename.patch"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050012SRC_URI[archive.sha256sum] = "418bb9fcffdbd72a98205ad365137617fc1e3551a54de74f6a98d45d266175bf"
Patrick Williams7784c422022-11-17 07:29:11 -060013
Patrick Williams8e7b46e2023-05-01 14:19:06 -050014PACKAGECONFIG ?= "goabackend kerberos owncloud lastfm google windows_live"
Patrick Williams7784c422022-11-17 07:29:11 -060015
Patrick Williams8e7b46e2023-05-01 14:19:06 -050016# goabackend requires webkitgtk to be built with gtk+3 and gcr3
Patrick Williams2a254922023-08-11 09:48:11 -050017PACKAGECONFIG[goabackend] = "-Dgoabackend=true,-Dgoabackend=false,gtk+3 gtk+3-native json-glib libxml2 libsoup rest libsecret webkitgtk3"
Andrew Geissler517393d2023-01-13 08:55:19 -060018PACKAGECONFIG[kerberos] = "-Dkerberos=true, -Dkerberos=false,krb5 gcr3"
Patrick Williams7784c422022-11-17 07:29:11 -060019PACKAGECONFIG[exchange] = "-Dexchange=true, -Dexchange=false"
20PACKAGECONFIG[google] = "-Dgoogle=true, -Dgoogle=false"
21PACKAGECONFIG[owncloud] = "-Downcloud=true, -Downcloud=false"
22PACKAGECONFIG[windows_live] = "-Dwindows_live=true, -Dwindows_live=false"
23PACKAGECONFIG[lastfm] = "-Dlastfm=true, -Dlastfm=false"
Patrick Williams7784c422022-11-17 07:29:11 -060024
25FILES:${PN} += " \
26 ${datadir}/dbus-1 \
27 ${libdir}/goa-1.0/web-extensions/*.so \
28"
29
30# looked into pkg-config file: it is not a bug - they mean it
31FILES:${PN}-dev += "${libdir}/goa-1.0/include"