blob: d3c6b421e69276ae9774584d78eeada8a5718c4d [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION = "Ceres Solver is an open source C++ library for modeling and solving large, complicated optimization problems."
Brad Bishop316dfdd2018-06-25 12:45:53 -04002HOMEPAGE = "http://ceres-solver.org/"
Brad Bishop316dfdd2018-06-25 12:45:53 -04003LICENSE = "BSD-3-Clause"
Andrew Geisslerac970dd2021-02-12 15:32:45 -06004LIC_FILES_CHKSUM = "file://LICENSE;md5=bb761279816b72be19d7ce646e4e2a14"
Brad Bishop316dfdd2018-06-25 12:45:53 -04005
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006DEPENDS = "libeigen glog"
7
Andrew Geissler595f6302022-01-24 19:11:47 +00008SRC_URI = "git://github.com/ceres-solver/ceres-solver.git;branch=master;protocol=https"
Patrick Williamsde0582f2022-04-08 10:23:27 -05009SRCREV = "f68321e7de8929fbcdb95dd42877531e64f72f66"
Brad Bishop316dfdd2018-06-25 12:45:53 -040010
11S = "${WORKDIR}/git"
12
Brad Bishop316dfdd2018-06-25 12:45:53 -040013inherit cmake
14
Patrick Williams213cb262021-08-07 19:21:33 -050015do_configure:prepend() {
Andrew Geissler32b11992021-03-31 13:37:05 -050016 # otherwise https://github.com/ceres-solver/ceres-solver/blob/0b748597889f460764f6c980a00c6f502caa3875/cmake/AddGerritCommitHook.cmake#L68
17 # will try to fetch https://ceres-solver-review.googlesource.com/tools/hooks/commit-msg durind do_configure
18 # which sometimes gets stuck (as there is no TIMEOUT set in DOWNLOAD)
19 # and we really don't need Gerrit's Change-Id tags when just building this
20 touch ${S}/.git/hooks/commit-msg
21}
22
Brad Bishopa891d152019-09-13 06:17:45 -040023# We don't want path to eigen3 in ceres-solver RSS to be
24# used by components which use CeresConfig.cmake from their
25# own RSS
26# ceres-solver/1.14-r0/packages-split/ceres-solver-dev/usr/lib/cmake/Ceres/CeresConfig.cmake: set(Eigen3_DIR ceres-solver/1.14-r0/recipe-sysroot/usr/share/eigen3/cmake)
27# ceres-solver/1.14-r0/packages-split/ceres-solver-dev/usr/lib/cmake/Ceres/CeresConfig.cmake: list(APPEND EIGEN_INCLUDE_DIR_HINTS ceres-solver/1.14-r0/recipe-sysroot/usr/include/eigen3)
28# ceres-solver/1.14-r0/packages-split/ceres-solver-dev/usr/lib/cmake/Ceres/CeresConfig.cmake: set(glog_DIR ceres-solver/1.14-r0/recipe-sysroot/usr/lib/cmake/glog)
29SSTATE_SCAN_FILES += "*.cmake"
30
31PACKAGECONFIG ??= ""
32
33# suitesparse* recipes will be in meta-ros layer
34PACKAGECONFIG[suitesparse] = "-DSUITESPARSE=ON,-DSUITESPARSE=OFF,suitesparse-config suitesparse-amd suitesparse-camd suitesparse-colamd suitesparse-ccolamd suitesparse-cholmod suitesparse-metis suitesparse-spqr"
35PACKAGECONFIG[cxsparse] = "-DCXSPARSE=ON,-DCXSPARSE=OFF,suitesparse-cxsparse"
36PACKAGECONFIG[lapack] = "-DLAPACK=ON,-DLAPACK=OFF,lapack"
37
Brad Bishop316dfdd2018-06-25 12:45:53 -040038# Only a static library and headers are created
Patrick Williams213cb262021-08-07 19:21:33 -050039RDEPENDS:${PN}-dev = ""
40RRECOMMENDS:${PN}-dev = "${PN}-staticdev"
41RRECOMMENDS:${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"