Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Linear Algebra PACKage" |
| 2 | URL = "http://www.netlib.org/lapack" |
| 3 | LICENSE = "BSD-3-Clause" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a32c99f24d097c72d1857e533b55642b" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 5 | |
| 6 | # Recipe needs FORTRAN support (copied from conf/local.conf.sample.extended) |
| 7 | # Enabling FORTRAN |
| 8 | # Note this is not officially supported and is just illustrated here to |
| 9 | # show an example of how it can be done |
| 10 | # You'll also need your fortran recipe to depend on libgfortran |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 11 | #FORTRAN:forcevariable = ",fortran" |
| 12 | #RUNTIMETARGET:append:pn-gcc-runtime = " libquadmath" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
| 14 | DEPENDS = "libgfortran" |
| 15 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 16 | SRCREV = "32b062a33352e05771dcc01b981ebe961bf2e42f" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 17 | SRC_URI = "git://github.com/Reference-LAPACK/lapack.git;protocol=https;branch=master" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | S = "${WORKDIR}/git" |
| 19 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 20 | PACKAGECONFIG ?= "" |
| 21 | PACKAGECONFIG[lapacke] = "-DLAPACKE=ON,-DLAPACKE=OFF" |
| 22 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | EXTRA_OECMAKE = " -DBUILD_SHARED_LIBS=ON " |
| 24 | OECMAKE_GENERATOR = "Unix Makefiles" |
| 25 | |
| 26 | inherit cmake pkgconfig |
| 27 | EXCLUDE_FROM_WORLD = "1" |