Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame^] | 1 | SUMMARY = "Provides API for encoding/decoding of data to/from D-Bus wire format" |
| 2 | DESCRIPTION = "This crate provides API for encoding/decoding of data to/from D-Bus wire format.\ |
| 3 | This binary wire format is simple and very efficient and hence useful outside of D-Bus context as well.\ |
| 4 | A modified form of this format, GVariant is very commonly used for efficient storage of arbitrary \ |
| 5 | data and is also supported by this crate." |
| 6 | HOMEPAGE = "https://gitlab.freedesktop.org/dbus/zbus/" |
| 7 | LICENSE = "MIT" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b377b220f43d747efdec40d69fcaa69d" |
| 9 | |
| 10 | SRC_URI = " \ |
| 11 | git://gitlab.freedesktop.org/dbus/zbus;protocol=https;branch=main;subpath=zvariant \ |
| 12 | file://0001-Tweak-zvariant-crate-config.patch;striplevel=2 \ |
| 13 | " |
| 14 | |
| 15 | SRCREV = "07506776fab5f58e029760bb4b288f670c7eecd6" |
| 16 | S = "${WORKDIR}/zvariant" |
| 17 | |
| 18 | python do_clean_lic_file_symlink() { |
| 19 | bb.utils.remove("LICENCE") |
| 20 | } |
| 21 | |
| 22 | addtask clean_lic_file_symlink after do_unpack before do_patch |
| 23 | |
| 24 | inherit cargo cargo-update-recipe-crates |
| 25 | |
| 26 | # Remove this when the recipe is reproducible |
| 27 | EXCLUDE_FROM_WORLD = "1" |
| 28 | |
| 29 | require ${BPN}-crates.inc |
| 30 | require ${BPN}-git-crates.inc |