Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Simple powerful testing with python" |
| 2 | HOMEPAGE = "https://pypi.org/project/pytest/" |
| 3 | DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries." |
| 4 | |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bd27e41b6550fe0fc45356d1d81ee37c" |
| 7 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame^] | 8 | SRC_URI[sha256sum] = "434afafd78b1d78ed0addf160ad2b77a30d35d4bdf8af234fe621919d9ed15e3" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 9 | |
| 10 | DEPENDS += "python3-setuptools-scm-native" |
| 11 | |
| 12 | inherit update-alternatives pypi python_setuptools_build_meta |
| 13 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 14 | RDEPENDS:${PN} += " \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 15 | ${PYTHON_PN}-atomicwrites \ |
| 16 | ${PYTHON_PN}-attrs \ |
| 17 | ${PYTHON_PN}-debugger \ |
| 18 | ${PYTHON_PN}-doctest \ |
| 19 | ${PYTHON_PN}-importlib-metadata \ |
| 20 | ${PYTHON_PN}-iniconfig \ |
| 21 | ${PYTHON_PN}-json \ |
| 22 | ${PYTHON_PN}-more-itertools \ |
| 23 | ${PYTHON_PN}-packaging \ |
| 24 | ${PYTHON_PN}-pathlib2 \ |
| 25 | ${PYTHON_PN}-pluggy \ |
| 26 | ${PYTHON_PN}-py \ |
| 27 | ${PYTHON_PN}-setuptools \ |
| 28 | ${PYTHON_PN}-six \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 29 | ${PYTHON_PN}-wcwidth \ |
| 30 | " |
| 31 | |
| 32 | ALTERNATIVE:${PN} += "py.test pytest" |
| 33 | |
| 34 | NATIVE_LINK_NAME[pytest] = "${bindir}/pytest" |
| 35 | ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest" |
| 36 | |
| 37 | ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test" |
| 38 | ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test" |
| 39 | |
| 40 | BBCLASSEXTEND = "native nativesdk" |