Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame^] | 1 | SUMMARY = "Python documentation generator" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 2 | HOMEPAGE = "http://sphinx-doc.org/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "BSD-2-Clause & MIT & BSD-3-Clause" |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=066da51ab732319a06beae4f10788577" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 6 | |
| 7 | PYPI_PACKAGE = "Sphinx" |
| 8 | |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "0dac3b698538ffef41716cf97ba26c1c7788dba73ce6f150c1ff5b4720786dd2" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 10 | |
| 11 | inherit python_flit_core pypi |
| 12 | |
| 13 | |
| 14 | do_install:append () { |
| 15 | # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?) |
| 16 | rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex* |
| 17 | } |
| 18 | |
| 19 | RDEPENDS:${PN} = "\ |
| 20 | python3-alabaster \ |
| 21 | python3-babel \ |
| 22 | python3-docutils \ |
| 23 | python3-imagesize \ |
| 24 | python3-jinja2 \ |
| 25 | python3-packaging \ |
| 26 | python3-pygments \ |
| 27 | python3-requests \ |
| 28 | python3-snowballstemmer \ |
| 29 | python3-sphinxcontrib-applehelp \ |
| 30 | python3-sphinxcontrib-devhelp \ |
| 31 | python3-sphinxcontrib-htmlhelp \ |
| 32 | python3-sphinxcontrib-jsmath \ |
| 33 | python3-sphinxcontrib-qthelp \ |
| 34 | python3-sphinxcontrib-serializinghtml \ |
| 35 | " |
| 36 | |
| 37 | BBCLASSEXTEND = "native nativesdk" |