Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Additional (old) themes for Xfwm4" |
| 2 | SECTION = "x11/wm" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 3 | LICENSE = "GPL-3.0-only" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 5 | |
| 6 | inherit xfce |
| 7 | |
| 8 | SRC_URI = "http://archive.xfce.org/src/art/${BPN}/${@'${PV}'[0:4]}/${BP}.tar.bz2" |
| 9 | SRC_URI[md5sum] = "eaa58362053a3549c8be0b32efd3c54f" |
| 10 | SRC_URI[sha256sum] = "3214d5f00e9703b5e8c9e7c3287d606dedec7285ceb4d5db332e93ada66fd575" |
| 11 | |
| 12 | # using xfwm4-theme as in xfwm4 might cause warnings of packages supplied by |
| 13 | # multiple providers. So we use xfwm4-old-theme here. |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 14 | python populate_packages:prepend () { |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 15 | themedir = d.expand('${datadir}/themes') |
| 16 | do_split_packages(d, themedir, '^(.*)', 'xfwm4-old-theme-%s', 'XFWM4 theme %s', allow_dirs=True) |
| 17 | } |
| 18 | |
| 19 | PACKAGES_DYNAMIC += "^xfwm4-old-theme-.*" |