Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "GNU file archiving program" |
| 2 | DESCRIPTION = "GNU tar saves many files together into a single tape \ |
| 3 | or disk archive, and can restore individual files from the archive." |
| 4 | HOMEPAGE = "http://www.gnu.org/software/tar/" |
| 5 | SECTION = "base" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 6 | LICENSE = "GPL-3.0-only" |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 8 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 9 | SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 10 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "7edb8886a3dc69420a1446e1e2d061922b642f1cf632d2cd0f9ee7e690775985" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 12 | |
| 13 | inherit autotools gettext texinfo |
| 14 | |
| 15 | PACKAGECONFIG ??= "" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 16 | PACKAGECONFIG:append:class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 17 | |
| 18 | PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 19 | PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 20 | |
| 21 | EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}" |
| 22 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | CACHED_CONFIGUREVARS += "tar_cv_path_RSH=no" |
| 24 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 25 | # Let aclocal use the relative path for the m4 file rather than the |
| 26 | # absolute since tar has a lot of m4 files, otherwise there might |
| 27 | # be an "Argument list too long" error when it is built in a long/deep |
| 28 | # directory. |
| 29 | acpaths = "-I ./m4" |
| 30 | |
| 31 | do_install () { |
| 32 | autotools_do_install |
| 33 | ln -s tar ${D}${bindir}/gtar |
| 34 | } |
| 35 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | do_install:append:class-target() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 37 | if [ "${base_bindir}" != "${bindir}" ]; then |
| 38 | install -d ${D}${base_bindir} |
| 39 | mv ${D}${bindir}/tar ${D}${base_bindir}/tar |
| 40 | mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar |
| 41 | rmdir ${D}${bindir}/ |
| 42 | fi |
| 43 | } |
| 44 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 45 | # add for ptest support |
| 46 | SRC_URI += " \ |
| 47 | file://run-ptest \ |
| 48 | file://0001-tests-fix-TESTSUITE_AT.patch \ |
| 49 | file://0002-tests-check-for-recently-fixed-bug.patch \ |
| 50 | file://0003-Exclude-VCS-directory-with-writing-from-an-archive.patch \ |
| 51 | " |
| 52 | |
| 53 | inherit ptest |
| 54 | |
| 55 | do_compile_ptest() { |
| 56 | oe_runmake -C ${B}/gnu/ check |
| 57 | oe_runmake -C ${B}/lib/ check |
| 58 | oe_runmake -C ${B}/rmt/ check |
| 59 | oe_runmake -C ${B}/src/ check |
| 60 | rm -rf ${S}/tests/testsuite |
| 61 | oe_runmake -C ${B}/tests/ testsuite |
| 62 | oe_runmake -C ${B}/tests/ genfile checkseekhole ckmtime |
| 63 | } |
| 64 | |
| 65 | do_install_ptest() { |
| 66 | install -d ${D}${PTEST_PATH}/tests/ |
| 67 | install --mode=755 ${B}/tests/atconfig ${D}${PTEST_PATH}/tests/ |
| 68 | sed -i "/abs_/d" ${D}${PTEST_PATH}/tests/atconfig |
| 69 | echo "abs_builddir=${PTEST_PATH}/tests/" >> ${D}${PTEST_PATH}/tests/atconfig |
| 70 | install --mode=755 ${B}/tests/atlocal ${D}${PTEST_PATH}/tests/ |
| 71 | sed -i "/PATH=/d" ${D}${PTEST_PATH}/tests/atlocal |
| 72 | install --mode=755 ${B}/tests/genfile ${D}${PTEST_PATH}/tests/ |
| 73 | install --mode=755 ${B}/tests/checkseekhole ${D}${PTEST_PATH}/tests/ |
| 74 | install --mode=755 ${B}/tests/ckmtime ${D}${PTEST_PATH}/tests/ |
| 75 | install --mode=755 ${S}/tests/testsuite ${D}${PTEST_PATH}/tests/ |
| 76 | sed -i "s#@PTEST_PATH@#${PTEST_PATH}#g" ${D}${PTEST_PATH}/run-ptest |
| 77 | } |
| 78 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 79 | PACKAGES =+ "${PN}-rmt" |
| 80 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 81 | FILES:${PN}-rmt = "${sbindir}/rmt*" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 82 | |
| 83 | inherit update-alternatives |
| 84 | |
| 85 | ALTERNATIVE_PRIORITY = "100" |
| 86 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 87 | ALTERNATIVE:${PN} = "tar" |
| 88 | ALTERNATIVE:${PN}-rmt = "rmt" |
| 89 | ALTERNATIVE:${PN}:class-nativesdk = "" |
| 90 | ALTERNATIVE:${PN}-rmt:class-nativesdk = "" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 91 | |
| 92 | ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar" |
| 93 | ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt" |
| 94 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 95 | PROVIDES:append:class-native = " tar-replacement-native" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 96 | NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}" |
| 97 | |
| 98 | BBCLASSEXTEND = "native nativesdk" |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 99 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 100 | # Avoid false positives from CVEs in node-tar package |
| 101 | # For example CVE-2021-{32803,32804,37701,37712,37713} |
| 102 | CVE_PRODUCT = "gnu:tar" |