Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # This recipe tracks the linux-yocto-dev repository as its upstream source. |
| 2 | # Since this tree is frequently updated, and periodically rebuilt, AUTOREV is |
| 3 | # used to track its contents. |
| 4 | # |
| 5 | # This recipe is just like other linux-yocto variants, with the only difference |
| 6 | # being that to avoid network access during initial parsing, static SRCREVs are |
| 7 | # provided and overridden if the preferred kernel provider is linux-yocto-dev. |
| 8 | # |
| 9 | # To enable this recipe, set PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-dev" |
| 10 | |
| 11 | inherit kernel |
| 12 | require recipes-kernel/linux/linux-yocto.inc |
| 13 | |
| 14 | # provide this .inc to set specific revisions |
| 15 | include recipes-kernel/linux/linux-yocto-dev-revisions.inc |
| 16 | |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 17 | KBRANCH = "v6.9/standard/base" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | KMETA = "kernel-meta" |
| 19 | |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 20 | SRC_URI = "git://git.yoctoproject.org/linux-yocto-dev.git;branch=${KBRANCH};name=machine;protocol=https \ |
| 21 | git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=master;destsuffix=${KMETA};protocol=https" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | |
| 23 | # Set default SRCREVs. Both the machine and meta SRCREVs are statically set |
| 24 | # to the korg v3.7 tag, and hence prevent network access during parsing. If |
| 25 | # linux-yocto-dev is the preferred provider, they will be overridden to |
| 26 | # AUTOREV in following anonymous python routine and resolved when the |
| 27 | # variables are finalized. |
| 28 | SRCREV_machine ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}' |
| 29 | SRCREV_meta ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}' |
| 30 | |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 31 | LINUX_VERSION ?= "6.9" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 32 | LINUX_VERSION_EXTENSION ?= "-yoctodev-${LINUX_KERNEL_TYPE}" |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 33 | PV = "${LINUX_VERSION}+git" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 34 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 36 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 37 | # yaml and dtschema are required for 5.16+ device tree validation, libyaml is checked |
| 38 | # via pkgconfig, so must always be present, but we can wrap the others to make them |
| 39 | # conditional |
| 40 | DEPENDS += "libyaml-native" |
| 41 | |
| 42 | PACKAGECONFIG ??= "" |
| 43 | PACKAGECONFIG[dt-validation] = ",,python3-dtschema-native" |
| 44 | # we need the wrappers if validation isn't in the packageconfig |
| 45 | DEPENDS += "${@bb.utils.contains('PACKAGECONFIG', 'dt-validation', '', 'python3-dtschema-wrapper-native', d)}" |
| 46 | |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 47 | COMPATIBLE_MACHINE = "^(qemuarmv5|qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64|qemuriscv32|qemuriscv64|qemuloongarch64)$" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 48 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 49 | KERNEL_DEVICETREE:qemuarmv5 = "arm/versatile-pb.dtb" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 50 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 51 | # Functionality flags |
| 52 | KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 53 | KERNEL_FEATURES:append = " ${KERNEL_EXTRA_FEATURES}" |
| 54 | KERNEL_FEATURES:append:qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc" |
| 55 | KERNEL_FEATURES:append:qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc" |
| 56 | KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc" |
| 57 | KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}" |
| 58 | KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc", "", d)}" |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 59 | KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/gpio/mockup.scc features/gpio/sim.scc", "", d)}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 60 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 61 | KERNEL_VERSION_SANITY_SKIP = "1" |