Howard Chiu | 0eb09a1 | 2021-12-09 13:27:04 +0800 | [diff] [blame] | 1 | LICENSE = "Apache-2.0" |
| 2 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 3 | |
Potin Lai | 807e2b2 | 2022-04-13 11:24:00 +0800 | [diff] [blame] | 4 | inherit allarch systemd obmc-phosphor-systemd |
Howard Chiu | 0eb09a1 | 2021-12-09 13:27:04 +0800 | [diff] [blame] | 5 | |
| 6 | RDEPENDS:${PN} += "bash" |
| 7 | RDEPENDS:${PN} += "libgpiod-tools" |
Potin Lai | 501f4c7 | 2022-06-13 13:23:57 +0800 | [diff] [blame] | 8 | RDEPENDS:${PN} += "bletchley-common-functions" |
Potin Lai | 2f800ca | 2022-10-21 19:19:25 +0800 | [diff] [blame] | 9 | RDEPENDS:${PN} += "mdio-tools" |
Howard Chiu | 0eb09a1 | 2021-12-09 13:27:04 +0800 | [diff] [blame] | 10 | |
| 11 | SRC_URI += " \ |
| 12 | file://bletchley-early-sys-init \ |
| 13 | file://bletchley-sys-init.service \ |
Potin Lai | 2f800ca | 2022-10-21 19:19:25 +0800 | [diff] [blame] | 14 | file://bletchley-host-state-monitor \ |
| 15 | file://bletchley-host-state-monitor.service \ |
Howard Chiu | 0eb09a1 | 2021-12-09 13:27:04 +0800 | [diff] [blame] | 16 | " |
| 17 | |
| 18 | SYSTEMD_PACKAGES = "${PN}" |
| 19 | SYSTEMD_SERVICE:${PN}:append = " \ |
| 20 | bletchley-sys-init.service \ |
Potin Lai | 2f800ca | 2022-10-21 19:19:25 +0800 | [diff] [blame] | 21 | bletchley-host-state-monitor.service \ |
Howard Chiu | 0eb09a1 | 2021-12-09 13:27:04 +0800 | [diff] [blame] | 22 | " |
| 23 | |
| 24 | do_install() { |
| 25 | install -d ${D}${libexecdir} |
| 26 | install -m 0755 ${WORKDIR}/bletchley-early-sys-init ${D}${libexecdir} |
Potin Lai | 2f800ca | 2022-10-21 19:19:25 +0800 | [diff] [blame] | 27 | install -m 0755 ${WORKDIR}/bletchley-host-state-monitor ${D}${libexecdir} |
Howard Chiu | 0eb09a1 | 2021-12-09 13:27:04 +0800 | [diff] [blame] | 28 | } |
Potin Lai | 807e2b2 | 2022-04-13 11:24:00 +0800 | [diff] [blame] | 29 | |
Patrick Williams | a2fb20c | 2024-02-05 14:11:29 -0600 | [diff] [blame] | 30 | SYSTEMD_OVERRIDE:${PN} += "bletchley-sys-init.conf:bletchley-sys-init.service.d/bletchley-sys-init.conf" |